Ubuntu 13.10 failed to boot

Asked by Vas


I installed Ubuntu 13.10 32 bit a few hours ago, dual booting with Windows 7. At the end of the installation, the bootloader failed to install, and it told I needed to manually install. I tried a lot of different things, and just tried boot-repair. It said there was an error and gave me this: paste.ubuntu.com/6463881

Windows is still fine, but there's no boot menu and I can't access the installed ubuntu OS - it directly boots Windows 7.

Please help.

Thank you.

I tried the Terminal method in http://www.howtogeek.com/114884/how-to-repair-grub2-when-ubuntu-wont-boot/
At the last step/command, I get this:
/usr/sbin/grub-bios-setup: warning: this LDM has no Embedding Partition; embedding won't be possible.
/usr/sbin/grub-bios-setup: error: embedding is not possible, but this is required for RAID and LVM install.

Question information

English Edit question
Boot-Repair Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Vas (vasishta94) said :

I seem to have fixed the bootloader issue. I rain the boot-repair and chose the GRUB Legacy option in a post somewhere by YannUbuntu, and it said it was successfully repaired - but it directly booted ubuntu,(couldn't access windows at all) and it didn't go past the Ubuntu screen(purple, with the logo and 5 dots which sequentially change from white to orange). I rebooted using the ubuntu install disk, and ran the boot-repair (without the GRUB Legacy this time) - and it again said that it was repaired successfully.
I rebooted and this time, and the GRUB boot menu showed up, and I could choose between Ubuntu, Advanced Ubuntu options, and my two windows partitions. I tried logging into windows and its fine, working normally. I rebooted and tried going into Ubuntu, but now the same issue is back where I can't get past the ubuntu purple loading screen. Those 5 loading dots are constantly changing colour/blinking. Been a while now. Is something wrong?

I pressed the arrow key and it shows this:
* Starting bluetooth daemon [ OK ]
* Starting startpar bridge for notification of upstart job start/stop [ OK ]
* Stopping startpar bridge for notification of upstart job start/stop [ OK ]
* Starting CUPS printing spooler/server [ OK ]
* Starting startpar bridge for notification of upstart job start/stop [ OK ]
* Starting cups-browsed - Bonjour remote printer browsing daemon [ OK ]
* Stopping startpar bridge for notification of upstart job start/stop [ OK ]

These lines are printed everytime I press the arrow key(and switch between this screen and the ubuntu loading screen).
Almost 1 hour and this screen hasn't gone.

Revision history for this message
YannUbuntu (yannubuntu) said :

Hello Vas
You were affected by this bug: https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/1061255

Now your new issue seems to be a problem linked to the kernel or the graphic card.

Revision history for this message
Vas (vasishta94) said :

Hello Yann,

I was able to fix the issue(s) - the GRUB was fixed by Boot-repair with GRUB Legacym and reboot(which led to direct ubuntu booting), and then another boot-repair with recommended settings(now the GRUB menu was showing up).
The other issue was fixable by updating from the live CD(chroot)..

Thank you :)