Windows 7 Option not appearing in grub even after repairing with boot-repair

Asked by Rajesh KSV on 2012-10-05

Hi All,

I have Windows 7 on my machine (Dell XPS 13) and then installed Ubuntu 12.04 using USB. I couldnot see grub screen, so I ran boot-repair (recommended repair). Now I can see grub but no windows option. Below is my paste ubuntu url. What can be the issue ?

http://paste.ubuntu.com/1260007/

Thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
Boot-Repair Edit question
Assignee:
No assignee Edit question
Solved by:
Rajesh KSV
Solved:
2012-10-08
Last query:
2012-10-08
Last reply:
2012-10-07
YannUbuntu (yannubuntu) said : #1

1) Restore direct boot to Windows this way: https://help.ubuntu.com/community/RestoreUbuntu/XP/Vista/7Bootloader
2) then use Boot-Repair's Recommended repair to recover the GRUb menu

Rajesh KSV (rajeshksv37-h) said : #2

May I know whats the issue here and why I need to do like this ?

I have a ultrabook , so I dont have a CD slot. So I gonna do from USB. That should be fine right ?

Rajesh KSV (rajeshksv37-h) said : #3

I wanted to know if I did anything wrong, so that from next time, I can avoid this.

Thanks for the suggestion :)

YannUbuntu (yannubuntu) said : #4

Some Windows boot files are missing. Maybe you deleted a separate Windows partition when you installed Ubuntu.
The procedure I gave you will regenerate those files.

Rajesh KSV (rajeshksv37-h) said : #5

Yes, I deleted the recovery partition and installed Ubuntu in it :) Looks like this is a bad choice. Damn! Will the above solution work even if I dont have my recovery partition ? Thanks

YannUbuntu (yannubuntu) said : #6

yes

Rajesh KSV (rajeshksv37-h) said : #7

I am not able to repair using windows DVD :( I tried to repair following this - http://www.howtogeek.com/howto/32523/how-to-manually-repair-windows-7-boot-loader-problems/ but in second screenshot, windows 7 option is not appearing. Even load drivers didnt help.I tried startup repair option in 3rd screenshot - It didnt work , then I followed command line method. First command worked bootrec /fixmbr but second command bootrec /fixboot failed. It says "the volume does not contain a recognized file system" . Please help me. I need my windows back badly :(

YannUbuntu (yannubuntu) said : #8

That's either a Windows issue, or a broken filesystem.
If i were you, i would try to recover my documents via TestDisk, then reinstall Windows, then recover GRUB via Boot-Repair.

Rajesh KSV (rajeshksv37-h) said : #9

Yes it is a windows issue and finally I got the solution. It seems first I have to make C partition active and then repair windows using above link. Worked like charm :) Now I am able to boot into windows but sadly grub is gone. But as you suggested, since windows repair is done, now i shall run boot-repair recommended setup again which I guess will restore grub

Thanks YannUbuntu for your awesome software and many many thanks for your even more awesome help.

Here is the summary of my fix which might help newbies who visit this page
1)I have deleted recovery partition of my Dell XPS 13 and installed Ubuntu on it
2)As a result windows got corrupted and didnt appear in grub
3)So, first I needed to fix windows. Made my C partition active (http://www.sevenforums.com/tutorials/71432-partition-mark-active.html)
4)Then I followed the same suggestions YannUbuntu mentioned in the first comment :)
5)It worked!

YannUbuntu (yannubuntu) said : #10

good job, and thanks for the feedback !