After running boot repair, neither Ubuntu or Windows will load

Asked by alasdair paterson

Hi, hope you can help.

I recently loaded Ubuntu on my HP laptop using WUBI. There were a few issues with it booting up to a blank screen etc so I had to add the following
parameters to Grub by holding down “Shift” after selecting Ubuntu, and then pressing “E”
nomodeset & acpi_osi=”Linux”

This allowed it to boot into Linux ok. There was no problem booting into Windows.

I had to make this change each time I logged in so I read that I needed to update Grub and can do this using the Boot Repair function.
I downloaded and ran it via the terminal. The Grub options were greyed out so I ran “Recommended Repair”.

Now it won’t boot at all. It says:

Windows failed to start, a recent hardware or software change might be the cause. Etc.....

The boot selection failed because a required device is inaccessible.

The error report is http:/

I tried running boot repair from a bootable CD but not sure what option to select. I tried running the repair again but no joy.

any suggestions?

Question information

English Edit question
Boot-Repair Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
YannUbuntu (yannubuntu) said :


Quote emails:

Hello Al,
You can try this:
1) Boot on a Ubuntu CD, choose "Try Ubuntu"
2) Backup your documents
3) Run Boot-Repair, click "Advanced options",
  - in the "Main options" tab, untick the "Repair Wubi filesystem" option,
  - in the "MBR options" tab, choose "Partition booted by the MBR: sda1"
4) Apply, indicate me the new URL that will appear
5) Reboot, and tell me what you observe

Sorry mate, I should have emailed back to say I’d fixed it.
I think I did something similar to what you suggested.
I booted from the boot-repair cd and tried a few different options.
There was Windows 7(sda1) and Windows 7(sda2) or something like that, I can’t remember.
I kept trying until one of them worked. Think it was blind luck.
But looks like your suggestion was spot on anyway.
Many thanks for the reply.