boot-repair upgrade fails

Asked by Maarten Jacobs on 2011-12-19

A new version of boot-repair was pushed today. During the installation I encountered the error:

E: /var/cache/apt/archives/clean_3.01-0ppa6~oneiric_all.deb: trying to overwrite '/usr/share/clean/cleancommon.sh', which is also in package clean-ubiquity-common 3-0ppa16~oneiric

Not sure if this is a bug or not, or whether I just need to re-install the lot?

Question information

Language:
English Edit question
Status:
Answered
For:
Boot-Repair Edit question
Assignee:
No assignee Edit question
Last query:
2012-01-10
Last reply:
2012-01-10

This question was reopened

Maurice Rogers (cruzer45) said : #1

Hi Maarten,

You can overcome get through this by running the following commands:

#First change to root
sudo su

#Then go to the apt cache directory
cd /var/cache/apt/archives/

#Install the package through dpkg forcing it to overwrite the new file
dpkg -i --force-overwrite clean_3.01-0ppa6~oneiric_all.deb

#run apt-get again just to make sure everything is ok
apt-get install -f

Let me know if these steps work for you.

yugnip (yugnip) said : #2

I had the same issue and the above instructions worked for me. Thank you.

Maarten Jacobs (maarten256) said : #3

Confirm - those steps did indeed fix the problem...

Maarten Jacobs (maarten256) said : #4

Thanks cruzer45, that solved my question.

Maurice Rogers (cruzer45) said : #5

No problem folks,

Glad to help.

Maarten Jacobs (maarten256) said : #6

Same problem happened again - now with boot-repair-common_3.04-0ppa3~oneiric_all.deb.

The noted instructions for resolving the problem still work.

However, it would appear that the root cause of the problem is that when I wait a number of days (about a week or so) in picking up updates, the "order" in which updates were supposed to be implemented gets lost and causes this behavior.

In other words, if I diligently apply the updates as they are published, rather than skipping an update or two, the problem does not occur. If I skip updates this problem does seem to occur?

YannUbuntu (yannubuntu) said : #7

Dear all,
this problem is a known bug when updating from version <3.03 to current version. It is due to packages name change, which brings package conflict during the self-update proposed at Boot-Repair start.
I explain how to solve this here: http://ubuntuforums.org/showpost.php?p=11594705&postcount=230

Sorry for the inconvenience.

Can you help with this problem?

Provide an answer of your own, or ask Maarten Jacobs for more information if necessary.

To post a message you must log in.