Addition to Context Menu for emptying Trash in Linux Release

Asked by Frank M Waterman on 2016-10-23

The rocknrollkid suggested that I post this here for you, Andrew.

Since BleachBit is seemingly the ONLY GUI based secure file deletion application available in Linux, I installed your most recent stable release on Ubuntu 16.04. I really like it so far, but there are two things I would really like to see added/changed in the next release.

The first thing that I would like to see changed is the need to enter the root password every time BleachBit is run. I understand that it was a conscious decision to disable creation of a root account in Ubuntu, but surely some method exists to have the password saved within BleachBit so that it can run as currently configured without re-entering the password first. Now, I also can see that this is a security risk if it would allow anyone else using the computer to modify BleachBit's settings, potentially deleting files that ought not to be deleted. So I would suggest that re-entering the root password to effect changes to BleachBit's configuration be implemented.

The feature I would like to see added is the addition of a shred and overwrite option added to the trashcan's context menu, so that users will have the option to securely delete all files contained in their system's trash can without actually launching BleachBit, à la the application Eraser for the Windows environment.

Question information

Language:
English Edit question
Status:
Solved
For:
BleachBit Edit question
Assignee:
No assignee Edit question
Solved by:
Andrew Ziem
Solved:
2016-10-23
Last query:
2016-10-23
Last reply:
2016-10-23
Best Andrew Ziem (ahziem1) said : #1

This ticket is about two things: the root password and the context menu. They are unrelated so they should be filed separately. Otherwise, it is difficult to manage them.

Also please report the as bug tickets and not questions because questions cannot be "fixed."

Regarding the passwords, I don't see this being supported in BleachBit. The next release after 1.12 will support PolicyKit, and then you can configure PolicyKit to bypass the password prompt. I haven't tried it, but Google suggests this http://askubuntu.com/questions/98006/how-do-i-prevent-policykit-from-asking-for-a-password

So the context menu suggestion I would refile as a bug ticket.

Thanks

Thanks Andrew Ziem, that solved my question.