after disc clean by bleach bit an unreadable, unremovable file

Asked by Tony Thomson on 2014-09-02

after deep scan an unreadable unremovable folder in home,how do I remove? tried rm -r and tried rm -rf in terminal, no joy

Question information

Language:
English Edit question
Status:
Answered
For:
BleachBit Edit question
Assignee:
No assignee Edit question
Last query:
2014-09-02
Last reply:
2014-09-02
Andrew Ziem (ahziem1) said : #1

Which version of BleachBit?

Would you please copy the error message verbatim?

Have you tried "sudo rm -rf"? You probably need this if you ran BleachBit as administrator. Let me know how that goes.

Andrew Ziem (ahziem1) said : #2

Reply from Tony via email

----------------
Hello Andrew thanks for respomding, I run linux mint 16 mate, did the
deep scan and an odd named folder apperared in my home folder, asked
caja to delete, big folder, 562 MB 1.4million files, (I run an older
laptop IBM X41) it failed to delete, went to sleep, apparently needed
permissions to read and write the files tried rm -r and rm -rf no joy,
but I did encounter problems trying to restart computer, it did load
eventually and is running normally
DeepScan seems to have unearthed something odd, similarly when I try to
operate disk usage analyser to have a look it seems to stall and I have
to end process.
suspect deep scan has scooped up some essential software somehow. and am
stuck with this mysterious folder in home

Andrew Ziem (ahziem1) said : #3

You may have used deep scan when this was created, but deep scan does not create any files or folders. This sounds like you were using the "wipe free disk space" in an obsolete version of BleachBit, and also the "wipe free disk space" process was prematurely aborted leaving the orphaned files.

Unless you are getting permission denied errors, "rm -rf" is actually working, but Linux file systems (like ext3 and ext4) are just very slow at deleting many files. You can monitor the progress by checking how many free inodes (where each file occupies one inode) using the command "df -i /home"

Sorry about the problem. Please allow patience for "rm -rf", and please update to the latest BleachBit or avoid aborting "wipe free disk space."

Also, in the future please communicate through LaunchPad answers instead of direct email. I think Launchpad has a way you can email your reply to Launchpad, but please check the "to" address.

Finally, please indicate in Launchpad whether this resolved your issue.

Can you help with this problem?

Provide an answer of your own, or ask Tony Thomson for more information if necessary.

To post a message you must log in.