Valac version used

Asked by Kurt Smolderen on 2012-06-29

Which version of the valac compiler should be used when compiling beatbox? I'm asking this question because granite.vapi has been removed from the repository in revision 639. Since then, I'm no longer able to compile using valac-0.16 as /usr/share/vala-0.16/vapi does not contain the missing vapi.

Should we use valac-0.14 instead?

Regards
Kurt

Question information

Language:
English Edit question
Status:
Answered
For:
BeatBox Edit question
Assignee:
No assignee Edit question
Last query:
2012-06-29
Last reply:
2012-07-01
Scott Ringwelski (sgringwe) said : #1

Victor is moving us to the development version of granite. I would start by installing granite from https://launchpad.net/~elementary-os/+archive/daily and if that does not fix the issue, report a bug.

Victor Martinez (victored) said : #2

Kurt, a port to a newer thread API is supposed to land within a couple of days, and that will force us to use valac-0.16 or newer. I'm glad to see you're using that version already, since all you need to do is installing the development version of granite to make it work.

Can you help with this problem?

Provide an answer of your own, or ask Kurt Smolderen for more information if necessary.

To post a message you must log in.