SQLheavy depency in fedora?

Asked by Drazgo on 2011-06-11

Hi there,

I'm trying to install Beatbox from source in fedora 15. I managed to get all depencies correct except for SQLheavy. I installed this library from source correctly (I suppose) but still "./waf configure" it gives me the error that it isn't installed.

Is there a way to exclude this depency in "./waf configure" or maybe you have another solution?

Thanks in advance!

Question information

Language:
English Edit question
Status:
Solved
For:
BeatBox Edit question
Assignee:
No assignee Edit question
Solved by:
Drazgo
Solved:
2011-06-12
Last query:
2011-06-12
Last reply:
2011-06-12
Scott Ringwelski (sgringwe) said : #1

Hello,

I will start by letting you know that I am not interested in supporting Fedora by any means. This is a music player for elementary OS, and so I try not to waste time supporting other OS's as it takes away from development time and is no fun. Buuut i'm feeling nice tonight.

One thing you could try is passing the following when configuring sqlheavy:

#for gir problems and sqlheavy
--enable-introspection=no to the configure/autogen.sh script

that has helped solve problems in the past.

There is no way to not compile with sqlheavy, no.

You should also check that sqlheavy's .vapi file is in the correct vala folder (vala-0.12 vs. vala 0.10 or something like that).

Other than that, I'm afraid I can't help you.

Best of luck and thanks for trying to use/using BeatBox!

Drazgo (laurens-helewaut) said : #2

Thanks for your answer! I already found what was wrong. SQLHeavy installed itself in the wrong directory for some odd reason. Anyway, people who are having the same issues can just download this file, extract it and copy it to their root dir "/" as a root:

http://rghost.net/download/10529111/dfe35730d29fca399279ec07bb4e0db4b10b0dbe/SQLHeavy-Fedora15.tar.gz

Now using beatbox and it rocks!