Whats up with the Indicate dep?

Asked by Hund on 2011-06-05

I was going to install the latest version from bzr today. But..

"[...]
Checking for 'indicate-0.5' >= 0.5.0 : not found
The configuration failed
(complete log in /tmp/clyde-johan/beatbox-bzr/beatbox-bzr/src/beatbox-build/build/config.log)
==> ERROR: A failure occurred in build().
    Aborting..."

Whats up with the Indicate dep? Im not using Ubuntu and I dont want the indicate thingy nor Zeitgeist. What do I do? Finding myself another music player? It seemse like your picking up Ubuntu deps and making Beatbox bloat?

Question information

Language:
English Edit question
Status:
Solved
For:
BeatBox Edit question
Assignee:
No assignee Edit question
Last query:
2011-06-05
Last reply:
2011-06-06
Scott Ringwelski (sgringwe) said : #1

We are working on making these optional.

And I don't see how a few dependencies and a few hundred lines of code for great functionality that is the sound menu support and zeitgeist is bloat.

Scott Ringwelski (sgringwe) said : #2

Solved

Hund (hund) said : #3

Thanks! :) For me it is:

$ sudo clyde -S libindicate
:: libindicate package not found, searching for group...
:: libindicate group not found, searching AUR...

==> Installing the following packages from repos

Targets (6): mono-2.10.2-1 gtk-sharp-2-2.12.10-1
            gnome-doc-utils-0.20.6-1 libgdiplus-2.10-1
            docbook-xml-4.5-4 rarian-0.8.1-1

Total Download Size: 34.63 MB
Total Installed Size: 149.07 MB

==> Installing the following packages from AUR
Targets (2): libindicate libdbusmenu

==> Proceed with installation? [Y/n]

And I would never ever install mono.

It should be fixed in rev 200. libindicate, libdbus-menu and zeitgeist are optional now.