I can't compile beat-box using Ubuntu 11.04

Asked by Joshua Lückers on 2011-05-23

Tried ./waf configure and this is the output:

Checking for 'gcc' (c compiler) : ok
Checking for program pkg-config : /usr/bin/pkg-config
Checking for 'gobject-2.0' : yes
Checking for 'gthread-2.0' : yes
Checking for program valac-0.8 : not found
Checking for program valac : /usr/bin/valac
Checking for valac version >= (0, 8, 0) : (0, 12, 0)
Checking for 'gtk+-2.0' >= 2.16.0 : not found

I am using valac-0.12. I am not sure if I have the right gtk+ version.

Question information

Language:
English Edit question
Status:
Answered
For:
BeatBox Edit question
Assignee:
No assignee Edit question
Last query:
2011-06-01
Last reply:
2011-06-02
Scott Ringwelski (sgringwe) said : #1

You're looking for the -dev packages. Such as gtk+-2.0-dev (not sure on real name).

Gusions (gusions) said : #2

You should install libgtk2.0-cil-dev!

Thanks for the answers. Installing the right gtk+ package seems to get me a little bit further. However I am now stick at taglib_c
I can not find the right package for that library either.

Scott Ringwelski (sgringwe) said : #4

Like I said, look for taglib or libtag, or something like that with the -dev extension. When in doubt, install them all.

libtag seems to be installed, but the error still occurs.

/usr/lib/libtag.so
/usr/lib/libtag.so.1
/usr/lib/libtag.so.1.6.3
/usr/lib32/libtag.so
/usr/lib32/libtag.so.1
/usr/lib32/libtag.so.1.6.3
/usr/lib64/libtag.so
/usr/lib64/libtag.so.1
/usr/lib64/libtag.so.1.6.3

Scott Ringwelski (sgringwe) said : #6

Closing this as it is answered.

Can you help with this problem?

Provide an answer of your own, or ask Joshua Lückers for more information if necessary.

To post a message you must log in.