Cannot compile, cannot find gio-2.0 >= 2.28.0

Asked by Kloplop321 on 2011-04-15

So, I'm trying to build this, I've searched everywhere, I cannot find gio at 2.28.0 or higher except in the openSuse repos. I'm trying to build this on ubuntu 10.10,
Here's what I have as a report,

./waf configure
Setting top to : /root/beat-box
Setting out to : /root/beat-box/build
Checking for 'gcc' (c compiler) : ok
Checking for program pkg-config : /usr/bin/pkg-config
Checking for 'gobject-2.0' : yes
Checking for 'gthread-2.0' : yes
Checking for program valac-0.8 : not found
Checking for program valac : /usr/bin/valac
Checking for valac version >= (0, 8, 0) : (0, 12, 0)
Checking for 'gtk+-2.0' >= 2.16.0 : yes
Checking for 'gee-1.0' >= 0.5.3 : yes
Checking for 'gstreamer-0.10' >= 0.10 : yes
Checking for 'taglib_c' >= 1.6.3 : yes
Checking for 'gio-2.0' >= 2.28.0 : not found
The configuration failed
(complete log in /root/beat-box/build/config.log)

 tail build/config.log
['/usr/bin/pkg-config', '--atleast-version=1.6.3', 'taglib_c']
['/usr/bin/pkg-config', 'taglib_c', '--cflags', '--libs']
out: -I/usr/include/taglib -ltag_c -ltag

yes
----------------------------------------
Checking for 'gio-2.0' >= 2.28.0
['/usr/bin/pkg-config', '--atleast-version=2.28.0', 'gio-2.0']
not found
from /root/beat-box: The configuration failed

Also, google thinking that I'm misspelling gio doesn't help me either.
Thanks in advance

Question information

Language:
English Edit question
Status:
Solved
For:
BeatBox Edit question
Assignee:
No assignee Edit question
Solved by:
Kloplop321
Solved:
2011-04-16
Last query:
2011-04-16
Last reply:
2011-04-16
Scott Ringwelski (sgringwe) said : #1

It looks like you got it to work. However, you actually don't need 2.28, it was a misconception. So I removed the dependency.

Kloplop321 (kloplop321) said : #2

Yes, It was somewhat infuriating.