does basenji support thumbnails for video files?

Asked by esteban jeldres on 2012-12-04

i was a GnomeCatalog user but i upgraded my computer to lubuntu 12.04 and it doesn't seem to work anymore so i switched to basenji but it does not show any thumbnail for video files, i wanted to know if it was because basenji has no thumbnail support for video files or if it is a problem whit my computer... thanx

Question information

Language:
English Edit question
Status:
Solved
For:
Basenji Edit question
Assignee:
No assignee Edit question
Solved by:
Patrick Ulbrich
Solved:
2012-12-06
Last query:
2012-12-06
Last reply:
2012-12-05
Best Patrick Ulbrich (pulb) said : #1

Hi esteban, thanks for your question.
Yes, Basenji does support video thumbnails. It uses totem-video-thumbnailer for that task, so make sure you have the totem package installed. Please let me know if installing that package solves your issue.

nope, installed the full totem package and it worked for playing the videos, i also cheked that i have a totem.thumbnailer file in /usr/share/thumbnalers and a totem-video-thumbnailer file in /usr/bin, i also uninstalled basenji, deleted the ~/.confi/basenji directory, and installed it again and still when i add a data dvd with some video files in it, it doesn't show any thumbnails... it only shows the video file icon... maybe its has somthing to do with the fact that lubuntu 12.04 comes with pcman as it's file manager and pcman does not support thumbnails for files over 32768 KB... i also have thunar file manager but not as the main file manager program, still thunar shows and generates video thumbnails for all the files...

Patrick Ulbrich (pulb) said : #3

What's the filetype of those video files (avi, mkv, ...)? Are the required codecs installed?
Supported thumbnailer files are located in ~/.gconf/desktop/gnome/thumbnailers. Please have a look in that directory and see if you have thumbnailers for your video files (e.g. video@x-avi ).

filetypes were avi, wmv, and mp4, and all codecs are present since all the videos play without problems... as for the gconf thumbnailers thats where the problem must be, i'll copye the contents of my ~/.gconf/desktop/gnome/thumbnailers directory:

esteban@esteban-P4VM800:~/.gconf/desktop/gnome/thumbnailers$ ls
application@pdf application@x-font-ttf
application@postscript application@x-font-type1
application@x-bzdvi application@x-gzdvi
application@x-bzpdf application@x-gzpdf
application@x-bzpostscript application@x-gzpostscript
application@x-cb7 application@x-xzpdf
application@x-cbr %gconf.xml
application@x-cbt image@tiff
application@x-cbz <email address hidden>
application@x-dvi image@x-bzeps
application@x-font-otf image@x-eps
application@x-font-pcf image@x-gzeps
esteban@esteban-P4VM800:~/.gconf/desktop/gnome/thumbnailers$

it's weird because i have thunar installed and thunar has thumbnail functionability...

Patrick Ulbrich (pulb) said : #5

OK, it seems you have an incomplete set of thumbnailes in there. Basenji writes the whole thumbnailer set to ~/.gconf/desktop/gnome/thumbnailers if this directory is empty. So please move all application* items to somewhere else (backup) and restart your computer. Then start a new scan in Basenji and check if you get movie thumbnails now.

Patrick Ulbrich (pulb) said : #6

Sorry, don't move just the application* items, move everything in ~/.gconf/desktop/gnome/thumbnailers somewhere else.

Patrick Ulbrich (pulb) said : #7

(thunar is probably using something else than gconf thumbnailers)

all right now, backed up ~/.gconf/desktop/gnome/thumbnailers and deleted all the contents in the directory, then restarted the computer and proceed to make basenji scan the dvd... it took it a little longer than before and this time it worked perfetly... all the files with their respective thumbnails... thank you so much for your time and preocupation, great software for organizing backup dvd collections, now its working with every feature, thanks for your help i hope this helps somewone else...

Thanks Patrick Ulbrich, that solved my question.

Patrick Ulbrich (pulb) said : #10

You're welcome! Nice to see it's working in lubuntu too :)