Migrating from ubuntu to baltix

Asked by Benas on 2007-10-31

How i could migrate from ubuntu 7.10 to baltix 3.0 ? I know that I need some upgrades . Where they are?

Question information

Language:
English Edit question
Status:
Answered
For:
Baltix Edit question
Assignee:
No assignee Edit question
Last query:
2008-12-05
Last reply:
2009-10-12
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Mantas Kriaučiūnas (mantas) said : #2

Benas asked:
> How i could migrate from ubuntu 7.10 to baltix 3.0 ? I know that I need some upgrades. Where they are?

Baltix is based on Ubuntu, so, you don't need to migrate, you could just install baltix-default-settings and baltix-desktop metapackages from official Baltix software repositories:

deb http://ftp.akl.lt/Linux/Baltix/Baltix-Ubuntu-packages gutsy main
deb http://ppa.launchpad.net/baltix-members/ubuntu/ gutsy main restricted universe multiverse
#Baltix3-Ubuntu7.10 paketų saugyklos

Also don't forget to upgrade all your upgradeable packages after you install baltix-default-settings and baltix-desktop metapackages - there are lots of fixed and improved packages in Baltix, comparing to Ubuntu stable version :)

Also there is a repository of "testing" packages:
#deb http://ppa.launchpad.net/mantas/ubuntu/ gutsy main restricted universe multiverse
#Testuojamų Baltix3/Ubuntu7.10 paketų saugykla

Software repositories for older or newer Baltix versions are the same, just replace "gutsy" with other Ubuntu version codename, which you need, for example if you wanna make Baltix from installed Ubuntu 7.04 version you should install baltix-default-settings and baltix-desktop metapackages from these Baltix software repositories:

deb http://ftp.akl.lt/Linux/Baltix/Baltix-Ubuntu-packages feisty main
deb http://ppa.launchpad.net/baltix-members/ubuntu/ feisty main restricted universe multiverse

look http://launchpad.net/~baltix-members/+archive for more info.

Btw, you can ask Baltix-related questions in Lithuanian or Russian languages, not only in English :)

Mantas Kriaučiūnas (mantas) said : #3

Baltix operacijų sistema yra sukurta Ubuntu pagrintu, todėl yra labai paprasta "atnaujinti" paprastą Ubuntu sistemą iki Baltix - tereikia įdiegti baltix-default-settings bei baltix-desktop metapaketus iš Baltix programinės įrangos saugyklų:
1. Viršutiniame meniu nueikite į Sistema->Administravimas->"Programinės įrangos saugyklos" (System->Administration->"Software Sources") ir pasirinkite kortelę "Trečių šalių programinė įranga". Tuomet paspauskite mygtuką "Pridėti..." (Add...) ir įrašykite šią eilutę:
deb http://ftp.akl.lt/Linux/Baltix/Baltix-Ubuntu-packages hardy main

Tuomet paspauskite mygtuką "+Pridėti saugyklą" ir palaukite, kol iš interneto atsiųs programų paketų informaciją.

Analogiškai galite pridėti ir šią Baltix programinės įrangos paketų saugyklą:
deb http://ppa.launchpad.net/baltix-members/ubuntu/ hardy main restricted universe multiverse

2. Pridėję Baltix programinės įrangos saugyklas nueikite į Sistema->Administravimas->"Paketų tvarkyklė Synaptic" (System->Administration->"Synaptic Package Manager") ir ten suradę baltix-default-settings bei baltix-desktop paketus pažymėkite juos įdiegimui (paspauskite 2 kartus ant jų) ir paspauskite mygtuką "Pritaikyti" (Apply)

Įdiegę bazinius Baltix programinės įrangos paketus nepamirškite atnaujinti visus galimus programų paketus - Baltix programinės įrangos saugyklose yra daug pataisytų ir patobulintų programų, kurių dar nėra Ubuntu stabilioje versijoje :)

Taip pat yra papildoma "Testuojamų" Baltix/Ubuntu programinės įrangos paketų saugykla:
deb http://ppa.launchpad.net/mantas/ubuntu/ hardy main restricted universe multiverse

Šios programinės įrangos saugyklos yra skirtos naujausiai - Ubuntu 8.04 "Hardy" versijai, jei įdiegėte kitą Ubuntu versiją - tiesiog pakeiskite žodį "hardy" į jūsų įdiegtos Ubuntu versijos kodinį vardą, pvz.: jei jūs norite padaryti Baltix iš Ubuntu 7.10 versijos - įdiekite baltix-default-settings and baltix-desktop metapaketus iš šių Baltix programinės įrangos saugyklų:

deb http://ftp.akl.lt/Linux/Baltix/Baltix-Ubuntu-packages gutsy main
deb http://ppa.launchpad.net/baltix-members/ubuntu/ gutsy main restricted universe multiverse

Daugiau informacijos ieškokite http://baltix.akl.lt bei http://launchpad.net/~baltix-members/+archive
FAQ #84: “Kaip pagerinti įdiegtą Ubuntu sistemą į Baltix ?”.

Knysliux001 (knysliux001) said : #4

O kaip dėl Ubuntu 8.10? Ar pakanka pakeisti hardy į intrepid?

Benas (benukaz) said : #5

nezinau nes nuo 7 versijos naudoju ubuntu :D

2008/12/5 Knysliux001 <email address hidden>

> Your question #16679 on Baltix changed:
> https://answers.launchpad.net/baltix/+question/16679
>
> Knysliux001 requested for more information:
> O kaip dėl Ubuntu 8.10? Ar pakanka pakeisti hardy į intrepid?
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/baltix/+question/16679
>
> You received this question notification because you are a direct
> subscriber of the question.
>

Launchpad Janitor (janitor) said : #6

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Mantas Kriaučiūnas (mantas) said : #7

Knysliux001 klausė:
> O kaip dėl Ubuntu 8.10? Ar pakanka pakeisti hardy į intrepid?

Taip, visas Ubuntu versijas galima patobulinti iki Baltix GNU/Linux tiesiog įdedant atitinkamas (pagal Ubuntu versijos kodinį pavadinimą) programinės įrangos saugyklas ir įdiegus baltix-desktop metapaketą, kaip jau rašiau aukščiau. Ubuntu 9.04 atveju kodinis pavadinimas būtų Jaunty, Ubuntu 9.10 - Karmic ir t.t.

Can you help with this problem?

Provide an answer of your own, or ask Benas for more information if necessary.

To post a message you must log in.