build error: Failed to build file '.built/bake.ver'

Asked by Adam Dingle on 2014-05-02

I'm trying to build Bake on Ubuntu 14.04. I ran 'bzr branch lp:bake' to get the code. Then I ran

$ cd bake
$ make

A bunch of output appeared, ending with

[Entering directory src]
TEMPLATE config.vala
TEMPLATE libbake.pc
BAKE-GET-SYMBOLS libbake.so.0
Failed to build file '.built/bake.ver'
[Build failed]
make: *** [all] Error 1

Am I doing something wrong, or is this a bug?

Question information

Language:
English Edit question
Status:
Solved
For:
Bake Edit question
Assignee:
No assignee Edit question
Solved by:
Adam Dingle
Solved:
2014-05-18
Last query:
2014-05-18
Last reply:
2014-05-05
Robert Ancell (robert-ancell) said : #1

The following works for me:
$ bzr branch lp:bake
$ cd bake
$ make LIBRARY_DIRECTORY=/usr/lib/x86_64-linux-gnu/

Could you edit the makefile and change the "all" target to have --verbose as a flag to bake-bootstrap?

Robert Ancell (robert-ancell) said : #2

(This is on Ubuntu 14.04 LTS)

Adam Dingle (adam-yorba) said : #3

OK - when I build using the LIBRARY_DIRECTORY argument you specified, the build works OK. So I'll close this. (Of course, it would be nice if the build worked automatically without specifying LIBRARY_DIRECTORY). Thanks!