backintime will not start

Asked by tjk on 2010-09-24

I'm wanting to start the backintime GUI. I have Kubuntu 10.04 installed (64-bit), but am running Lubuntu desktop most the time.
I have tried using the app menu but both the root and standard backintime buttons don't start the app. When I run backintime in the terminal I get:
   File "/usr/share/backintime/kde4/app.py", line 1019, in <module>
    app_instance = guiapplicationinstance.GUIApplicationInstance( cfg.get_app_instance_file(), raise_cmd )
  File "/usr/share/backintime/common/guiapplicationinstance.py", line 40, in __init__
    self.start_application()
  File "/usr/share/backintime/common/guiapplicationinstance.py", line 82, in start_application
    file = open( self.pid_file, 'wt' )
IOError: [Errno 13] Permission denied: '/home/tim/.local/share/backintime/app.lock.pid'

Question information

Language:
English Edit question
Status:
Answered
For:
Back In Time Edit question
Assignee:
No assignee Edit question
Last query:
2010-09-24
Last reply:
2014-12-18
Dan (danleweb) said : #1

Please check you permission in: home/tim/.local/share/backintime/app.lock.pid

scuba (scubuntu) said : #2

Hi there,

I have the same error here. I've tried changing the ownership and permission of home/scuba/.local/share/backintime/app.lock.pid with no result. The Error still reads :

--[E] Can't find snapshots folder.
If it is on a removable drive please plug it. --

regards

SCUBA

tjk (tim-klassen) said : #3

I did get mine working... both the user and the group were set to root for some reason, so when I changed them to my username everything worked fine.

I can't remember if I had to change the permission of the "backintime" folder... did you check that folder to see if permissions were correct?

scuba (scubuntu) said : #4

Hi,

I changed permissions to the backintime configuration folders as above. All permissions are mine... read/write and ownership, group is mine... still there is a problem. BiT keeps telling me that it cannot find the snapshots folder, although it is mounted and available. BiT even lists the snapshots it supposedly can't find...

The error message in the GUI is --[E] Can't find snapshots folder.
If it is on a removable drive please plug it. --

This is not good... I only recently changed my entire backup-strategy and implemented BiT systemwide. I hope this can be solved easily?

Regards and many thanks

SCUBA

scuba (scubuntu) said : #5

Hi there,

I simply deleted home/scuba/.local/share/backintime\ completely and restarted BiT... that seemed to work.

Problem solved

regards

SCUBA

Dan (danleweb) said : #6

I think there can be a problem if you upgrade BIT while it is taking a snapshot.

BerPetru (bernyguitar) said : #7

Hi, give permisions to the path: sudo chmod 777 /home/tim/.local/share/backintime/app.lock.pid

Can you help with this problem?

Provide an answer of your own, or ask tjk for more information if necessary.

To post a message you must log in.