Where is ActivateBehavior configuration ?

Asked by ikus060


I'm a big fan of Viewport and got some problem to get AWN working as I expect. So far, When I click on a launcher that are already open, it's get active in a strange way - the icons start jumping but the window never appear in the viewport.

I was about to modify the code it self to get the expected result to finally notice the code is already present but the configuration are not available in awn-manager. I refer to window_manager/activate_behavior.

Is there any reason why this configuration are not available in amw-manager ??


Patrik Dufresne

Question information

English Edit question
Awn Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Best moonbeam (rcryderman) said :

1) It's a newly added config option.
2) We tend to be rather conservative about adding options to awn-manager as their addition implies a commitment to keeping them around.
3) Awn-manager changes are more or less frowned upon until the 0.4 rewrite when the configuration manager is due for a rewrite.

Revision history for this message
ikus060 (ikus060-renamed) said :

Hi moonbeam,

Thanks for you reply.

My only hope is to see this setting in awn-manager in nest release ...


Patrik Dufresne

Revision history for this message
ikus060 (ikus060-renamed) said :

Thanks moonbeam, that solved my question.