AWN will only start with sudo

Asked by brendan

At the moment I can only get AWN to work if I use sudo:

$ sudo avant-window-navigator
Screen is composited.
APPLET : /usr/lib64/awn/applets/taskman.desktop

And it works fine.

Without sudo:
$ avant-window-navigator
Screen is composited.

** (avant-window-navigator:6242): WARNING **: Could not load the desktop item at '/home/brendan/.config/awn/launchers/awn_launcher.desktop': No such file or directory
Segmentation fault

I have tried
$ touch .config/awn/launchers/awn_launchers.desktop

but that changed the error message to "file is empty"

And when I try to run it as root:
# avant-window-navigator

** (avant-window-navigator:6281): WARNING **: Failed to make connection to session bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

** (avant-window-navigator:6281): CRITICAL **: dbus_g_proxy_new_for_name: assertion `connection != NULL' failed

** (avant-window-navigator:6281): CRITICAL **: dbus_g_proxy_call: assertion `DBUS_IS_G_PROXY (proxy)' failed

** (avant-window-navigator:6281): WARNING **: There was an error requesting the name: (null)
Segmentation fault

I have tried to remove the awn folder in the hope that it would recreate itself - with no effect.
I am running KDE 3.5 with compiz and emerald all working fine using a nvidia 9300 card.

Question information

English Edit question
Awn Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Guyverix (guyverix) said :

have you looked in /root for the .config file that was generated? or do a locate for it? Once you find it, cheat, do a cp -R for the directory structure into your home directory, and chown it to your userid and group name. LMK how that works for you.

Revision history for this message
Michal Hruby (mhr3) said :

If you're using GConf backend use `gconftool-2 --unset /apps/avant-window-navigator/window_manager/launchers`.

Can you help with this problem?

Provide an answer of your own, or ask brendan for more information if necessary.

To post a message you must log in.