Awn

Nautilus doesn't start when autostarting awn

Asked by piet85 on 2009-01-03

Hello at all!
I switched from Fedora 8 to Fedora 10 (both x86_64) with a new installation. I kept my /home partition as it was and also the configuration files of AWN stored in /home. So AWN after installing looked like in Fedora 8. All worked fine, except clicking on the starter for Nautilus: Nothing happened. After restarting AWN it worked. At least if I start AWN manually (from terminal or desktop-starter) it works, if I start it with my desktop (I registered it in the "session" configuration) it wouldn't.
I also tried following steps:
- delete the starter and create a new one
- completely reset AWN and configure it again
- delete and register the entry to start awn in "sessions" again
- trying to get some error code -> my problem is to reproduce the bug in a way I get some error code (If I start it from terminal it is a restart, so the bug does not appear, if I start it with my desktop I found no way to start it with a terminal)
Can anyone tell me what's going wrong with my AWN or where/how I can get an error prompt to find out?

Question information

Language:
English Edit question
Status:
Solved
For:
Awn Edit question
Assignee:
No assignee Edit question
Solved by:
piet85
Solved:
2009-01-05
Last query:
2009-01-05
Last reply:
2009-01-04
Mark Lee (malept) said : #1

Try middle-clicking.

The problem is that nautilus is autostarted when you login to your desktop, so when you have a nautilus launcher, Awn thinks that it has already been launched, and so it associates that nautilus process with the launcher. Middle-clicking allows you to launch a separate process for a launcher that already has a task associated with it.

piet85 (peterhoffm) said : #2

Sorry that didn't solve the problem.
Middle clicking on the Nautilus launcher makes appear the AWN-manager. After trying this on other starters which programs aren't started, I found out this happens every time you click on a starter that isn't launched at all, so Nautilus could not be launched.
At least Nautilus behaves a little bit different than other programs in AWN (I just can talk for my system, I don't know whether this is normal behavior, but it never annoyed me in any way and it always did like this, so I took it for granted): By clicking on the starter it opens Nautilus and a new nautilus-task appears in the task bar. Another click will open another Nautilus window, so even if it's running, it should open a new window. It behaved this way in F8 and it also does when it is started manually, just when it is autostarted it won't.

PSeeCO (skann3r) said : #3

Same problem here, and middle clicking didn't solve...

piet85 (peterhoffm) said : #4

So now it get's really weird. After a lot of searching I found the command gnome-terminal -e to autostart awn in terminal. I wrote a bash script: "gnome-terminal -e avant-window-navigator" made it executable and wrote an entry for "session". Next login a terminal opened prompting the error that compiz isn't running (ok at this point it wasn't running). After compiz started it worked all fine. Only error I got was this one: "Traceback (most recent call last):
  File "/usr/lib64/awn/applets/showdesktop/showdesktop.py", line 61, in __leave_notify
    self.title.hide (self)" but that's just because there is no text over the showdesktop icon I guess.
So I tried that script only starting awn without the terminal and wrote: "avant-window-navigator" After login the same problem like before, Nautilus didn't open.
Is it possible that awn starts to early, so Nautilus isn't ready at that point? And the terminal slows down the awn startup? That would also explain why all works fine starting it manually. Is there any Possibility to delay the starting of awn or set it as last autostarted program?

I can't reproduce the problem here, but if you want to delay AWN from starting use something like the following in your sessions:

sleep 10 && avant-window-navigator

piet85 (peterhoffm) said : #6

I tried up to 30 seconds without any success, so this couldn't cause the problem.
You tried to reproduce the problem with fedora 10? Any Idea how I can get some bug report out of awn?

piet85 (peterhoffm) said : #7

I got it!
Ok, I've got no reason why, normally the command "nautilus" simply should do the job, but it does not. I tried entering the directory of the userhome behind Nautilus in the AWN-starter: "nautilus /home/userhome". For me it works very well, please tell me if that workaround fixed your problem too PSeeCO!

PSeeCO (skann3r) said : #8

Perfect Piet, it works! Thanks so much!