Awn

Remove awn 0.2.1

Asked by ublo on 2008-05-28

Hi,

Some months ago I've installed AWN v0.2.1 on my Ubuntu 7.04 by following a manual installation with a terminal.

When I've installed ubuntu 7.1 and today with 8.04, I've 3 verticals lines on the right of the dock.

Tired to look this and as now awn is included into synaptic, I would like to remove it and reinstall it by synaptic.
Unfortunately, as it was a manual install nothing is seen into synaptic and I didn't find how to remove it.
When I install it by synaptic I have 2 docks.

Can you help me ?

Thx

Question information

Language:
English Edit question
Status:
Solved
For:
Awn Edit question
Assignee:
No assignee Edit question
Solved by:
ublo
Solved:
2008-05-30
Last query:
2008-05-30
Last reply:
2008-05-30

Navigate to the directory where you installed AWN v0.2.1 from and then run the command "sudo make uninstall"

If you deleted the downloaded source, you can still download the old version from: http://edge.launchpad.net/awn/0.2/0.2.1/+download/avant-window-navigator-0.2.1.tar

Unpack it, and then run "sudo make uninstall" from inside that directory.

You should then reinstall AWN through synaptic.

ublo (loichello) said : #2

Hi Andrew

How can I find this directory ? I found 5 directory :
/user/local/share/avant-window-navigator/awn-manager
/usr/local/lib/awn
/usr/local/lib/python2.5/site-package/awn
/usr/local/include/libawn
/usr/share/doc/libawn0

When I execute sudo make uninstall on the first one I receive a message "make : no rules to build unsintall target. stop"
I put the download mentionned in this directory and obtain same error message.

Ths

It's the same directory you originally compiled and installed awn from. When you say "manual installation with a terminal" I assume you mean that you installed by running:

 ./configure
 make
 sudo make install

So to uninstall run "sudo make uninstall" in that same directory.

If you deleted that directory, download the old version from: http://edge.launchpad.net/awn/0.2/0.2.1/+download/avant-window-navigator-0.2.1.tar

Unpack it, and then run "sudo make uninstall" from inside that directory.

ublo (loichello) said : #4

Hi,

Indeed, that's what I've done but I don't remember at all the directory. maybe it still somewhere, maybe not.
If I follow your instruction with download it again and unpack it in /home/ublo/Desktop/awn021, when I launch "sudo make uninstall" I got the message "make : no rules to build uninstall target. stop".

Ths

Mark Lee (malept) said : #5

You'll have to re-run ./configure and then run `sudo make uninstall`.

ublo (loichello) said : #6

When I type ./configure I got an error message "bash: ./configure: no such file or directory"

Mark Lee (malept) said : #7

I suppose I should have been more detailed in my response, sorry.

Instructions:

cd /home/ublo/Desktop/
tar -xf /path/to/avant-window-navigator-0.2.1.tar # please replace the path with the absolute location of the tar file
cd avant-window-navigator-0.2.1
./configure
sudo make uninstall

ublo (loichello) said : #8

we go ahead but while running ./configure I got this error message :
"configure: error: C compiler cannot create executables
See `config.log' for more details."

As this config.log is a bit long tell me if you want to have it or just some parts

ths

Mark Lee (malept) said : #9

Run the following in a terminal:

which gcc

If that says "which: no gcc in ...", then we have a problem (and I wonder how you installed Awn from source in the first place).
If that prints a path to gcc (for example, /usr//bin/gcc), then run the following:

gcc --version

and post the output here.

ublo (loichello) said : #10

since then I've installed build-essential & pygtk-dev as I've seen in an ubuntu forum that it's the minimum required.
But now ./configure need all that : glib-2.0 gobject-2.0 gtk+-2.0 gdk-2.0 libwnck-1.0 gnome-desktop-2.0 libgnome-2.0 gnome-vfs-2.0 gconf-2.0 x11 xproto dbus-glib-1 libglade-2.0 xdamage xcomposite xrender.
Do you know some meta package that include all that packages ?

To answer to your question :
which gcc : /usr/bin/gcc
gcc --version : gcc (GCC) 4.2.3 (Ubuntu 4.2.3-2ubuntu7)

thx

Mark Lee (malept) said : #11

there is a list in the debian package control file:

http://bazaar.launchpad.net/~awn-core/awn/trunk/annotate/head:/debian/control

Look in the "build-depends" section, and ignore the valac and python2.5 lines (they are not applicable to the version you're trying to uninstall).

ublo (loichello) said : #12

It succeed :-) thanks for your help. definitively I couldn't do it alone !
Bye