HELP ME PLEASE--No access to anything--removed launchpad trying to fix duplicate issue

Asked by bujutsukai

So, I had a similar problem to that of the user in question #11691--I was getting duplicate icons for programs launched (firefox, pidgin, evolution, etc.) I followed the advice (I thought) of the answerer, and removed an AWN launcher from Applet that appeared to be a duplicate. As soon as I did that, my AWN is not there anymore, and I don't know any way to access anything (if I didn't have Firefox open when this happened, I wouldn't even be able to ask this question). I'm very new with Linux, but am enjoying it, mostly.

I'm on Ubuntu 7.10 with all panels gone (I really like the OS X look that AWN can provide).

Can anyone help? My computer is useless to me until this is resolved.

Thanks in advance.

Question information

English Edit question
Awn Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
moonbeam (rcryderman) said :

Awn will often crash when that particular applet is removed. Awn can normally be restarted afterwards without issue. If you have the ability to run a command just run avant-window-navigator.

Also, chances are that awn will restart normally by a logout/login of gnome... though it's not guaranteed as it depends on it previously being configured to start on login.

Revision history for this message
bujutsukai (thomaslanphear) said :

Hi moonbeam! Thanks for your reply! I'm scared now like I should have been before I did this :-(

Unfortunately, I don't have a quit/logout/restart option, that I'm aware of, other than pressing the button and powering down and then back up. Also, if I did use that route, and it didn't work, I wouldn't have the first clue how to open any application (like Firefox) to ask for more help. I think I'm looking for something a little more indepth, that will give me enough confidence to actually go through a shut down.

Do you have any additional suggestions? I would certainly appreciate them.

Thanks again ;-)

Revision history for this message
moonbeam (rcryderman) said :

Try to right click on you desktop. You should get a menu and one of the options should be "Create Launcher". Choose that. A window will open. Type awn int the "Name" and where it says Command type avant-window-navigator. Press ok.

You should have a new icon on your desktop. Double click on the icon and awn should start up.

Revision history for this message
pavpanchekha (pavpanchekha) said :

OOh, you've gotten yourself into a fix...

Do you have a desktop (IE, can you right click on it and get a menu?)

If so:
Right click, add launcher,

Name: "Gnome-panel"
Command: "gnome-panel"

and double click it to start gnome-panel (you can kill it later after you fix everything.
That way, you have access to all your programs. From there, you can try starting AWN again.

Revision history for this message
bujutsukai (thomaslanphear) said :

That worked, though it was easy enough that I should have known it. I know it now, just in case.