Awn

debian control file doesn't build python-awn-trunk

Asked by spool on 2008-01-03

Hi. Many thanks for the excellent application.

I'm having trouble building debian packages from the development (trunk) branch (rev 154). I'm on a powerbook running debian sid. I've never built a debian package before, which is why I'm not filing a bug report (I presume I've done something wrong).

Using the debian folder so conveniently provided, I typed:

sudo dpkg-buildpackage -rfakeroot

I waded through the missing dependencies until I ran into the following:

(apologies, I don't know if I can use code formatting with launchpad)

...
dh_link -ppython-awn-trunk
dh_pycentral -ppython-awn-trunk
dh_python -ppython-awn-trunk debian/tmp/usr/share/avant-window-navigator/awn-manager/
dh_python: Doing nothing since dh_pycompat exists; dh_pysupport or dh_pycentral should do the work. You can remove dh_python from your rules file.
dh_scrollkeeper -ppython-awn-trunk
dh_gconf -ppython-awn-trunk
dh_desktop -ppython-awn-trunk
dh_strip -pavant-window-navigator-trunk --dbg-package=libawn0-trunk-dbg
dh_strip: debug package libawn0-trunk-dbg is not listed in the control file
make: *** [binary-strip-IMPL/avant-window-navigator-trunk] Error 1
dpkg-buildpackage: failure: fakeroot debian/rules binary gave error exit status 2

The second problem seemed easy enough to fix: I stuck a placeholder section for trunk-dbg into debian/control

...(right after the python section)
Package: libawn0-trunk-dbg
Section: universe/gnome
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends},
Description: Debugging for AWN
 Debugging package for Avant Windows Navigator

That solved the dbg problem, but the python package is still not being built (and is presumed superfluous?). This is clearly a problem for the mimenu, at least:

$ avant-window-navigator
Screen is composited.
LOADED : ~/.config/awn/launchers/awn_launcher-1.desktop
LOADED : ~/.config/awn/launchers/awn_launcher-2.desktop
APPLET : ~/testing/lib/awn/applets/taskman.desktop
APPLET : ~/.config/awn/applets/mimenu.desktop
Traceback (most recent call last):
  File "~/.config/awn/applets/mimenu/mimenu.py", line 25, in ?
    import awn
ImportError: No module named awn

(I've replace /home/myusername with ~ in the above section)

looking into debian/python-awk-trunk/usr/lib/python2.4/site-packages/awn, I see the missing module.

Now, I could just symlink the awn module, as well as the other parts of the python trunk, into my system, but that's not very debian :).

So: is it a bug or have I done something stupid?

thanks very much,

-spool-

Question information

Language:
English Edit question
Status:
Answered
For:
Awn Edit question
Assignee:
No assignee Edit question
Last query:
2008-01-03
Last reply:
2008-01-04

Could you attempt to build the deb again with the newest rev. I think it might fix your issue.

155. By Julien Lavergne <seagle@justice> 23 hours ago

2008-01-03 Julien Lavergne <email address hidden>

 * awn-applet-activation/main.c:
 patch by: moonbeam
 Fix bug #179232 : Don't use Type field of desktop files

 * debian/control.autoppa:
 * debian/changelog:
 * debian/control:
 Clean debian/control
 Properly set the debug package

Can you help with this problem?

Provide an answer of your own, or ask spool for more information if necessary.

To post a message you must log in.