Xubuntu 7.10 & AWN - cannot add launcher

Asked by Rangerst

I have installed the Gutsy packages following instructions on the forums.

awn-manager starts ok but when I click on the add button on the launcihers tab nothing happens.

If I start awn-manager from console I can capture this error message when I click on the "add" button:

Traceback (most recent call last):
  File "/usr/share/avant-window-navigator/awn-manager/", line 213, in add
    process = subprocess.Popen(['gnome-desktop-item-edit', file_path], env=os.environ)
  File "/usr/lib/python2.5/", line 593, in __init__
    errread, errwrite)
  File "/usr/lib/python2.5/", line 1135, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory

I guess this means AWM is looking for gnome stuff and as I am running XFCE can't find them. Is there a fix for this? or a workaround so I can uses AWN with Xubuntu & Compiz-fusion?



Question information

English Edit question
Awn Edit question
No assignee Edit question
Solved by:
Mark Lee
Last query:
Last reply:
Revision history for this message
Best Mark Lee (malept) said :

Unfortunately, one of the dependencies of Awn is gnome-panel, because it was a convenient way to provide custom launcher support for Awn.

There are two alternatives:
1. Drag and drop .desktop files from Thunar onto the dock. Make sure you don't delete the .desktop files afterwards, because Awn uses them to get the application data.
2. Compile/install my desktop-agnostic branch, which contains a pure python implementation of a launcher editor, and only requires python-xdg (AKA pyxdg) to run. (There may be other dependencies, depending on the ./configure flags passed at compile time).

I recommend the first option, since it is more stable. The desktop-agnostic branch is considered experimental, although I'm currently dogfooding it.

Revision history for this message
Rangerst (rangerst) said :

Thanks Mark Lee, that solved my question.

Revision history for this message
yvan (yvan-strahm) said :

I am using xubuntu 8.04, Xfce 4.4 version 4.4.2 and awn 0.3.1 and the drag and drop didn't worked for me. The solution is to drag and drop with the ctrl key pressed, this was necessary only for the first launcher after the ctrl key was not necessary anymore....
Hope this will help someone having problem adding launchers