Awn

AWN and how to launch program in terminal

Asked by rbaleksandar on 2011-05-15

Hi!

  Before filing a bug report, I wanted to make sure I'm doing things like they are supposed to be done. I'm using Ubuntu 10.04 and AWN 0.4.0. I want to add Midnight Commander (and other terminal-programs, if that matters) to AWN. I created a new task from the Task Manager and specified that the task has to run in terminal. After that when I click on the new launcher in AWN, it bounces (I've chosen the classic icon effect) but nothing seems to happen. Looked in the process list in System Monitor but could not find MC or whatever. Then I tried to add another task with another terminal-program - ELinks. Same old story - icon bounces but no terminal with the running program inside it appears on the screen or as a process.

  Is this a bug or is it just me doing something wrong?

Greeting and thanks in advance,
RB

Question information

Language:
English Edit question
Status:
Solved
For:
Awn Edit question
Assignee:
moonbeam Edit question
Solved by:
Gabor Karsay
Solved:
2011-05-28
Last query:
2011-05-28
Last reply:
2011-05-28
Best Gabor Karsay (gabor-karsay) said : #1

Yes, that's a bug in libdesktopagnostic. The linked bug report is about the Cairo Menu applet but it seems to be valid for the taskmanager, too because it's working now. You'll need to install Awn from the PPA.

rbaleksandar (redbaronqueen) said : #2

Thanks @Gabor Karsay (for the tip) and @moonbeam (for linking my question to an existing bug report). I added the PPA to my sources list, did an update and now it's working - clicking on an application (that has to run in terminal) immediately starts the terminal and the application in it. :)

Best regards and thanks again!
rb

rbaleksandar (redbaronqueen) said : #3

Thanks Gabor Karsay, that solved my question.