Awn

I am getting an error compliling 0.2 from source on Gutsy

Asked by corey1981 on 2007-10-08

I am getting the following error trying to install from source on Gutsy Gibbon

make[2]: Entering directory `/home/corey/Desktop/avant-window-navigator-0.2/po'
file=`echo ar | sed 's,.*/,,'`.gmo \
          && rm -f $file && -o $file ar.po
/bin/sh: -o: not found
make[2]: *** [ar.gmo] Error 127
make[2]: Leaving directory `/home/corey/Desktop/avant-window-navigator-0.2/po'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/corey/Desktop/avant-window-navigator-0.2'
make: *** [all] Error 2

./configure finished fine without errors

Question information

Language:
English Edit question
Status:
Solved
For:
Awn Edit question
Assignee:
No assignee Edit question
Solved by:
corey1981
Solved:
2007-10-08
Last query:
2007-10-08
Last reply:
2007-10-08

same here

have you installed the needed dependencies for AWN?

sudo apt-get install build-essential autotools-dev libxdamage-dev libxcomposite-dev libgnome2-common libgnome2-dev libgnome-desktop-dev libgnome-vfs-dev libgtk2.0-dev libwnck-dev libgconf2-dev libglib2.0-dev libdbus-glib-1-dev libgnomevfs2-0 libgnome-desktop-2 libgnome2-0 libwnck-common python-gtk2 python-gconf bzr gnome-common python-dev python-gtk2-dev python-cairo-dev python-gconf python-gnome2-dev

hope this helps.

corey1981 (corey1981) said : #3

I ended up downloading the source via BZR and compiling it and getting it working.

mrb1ggles (nmacaulay) said : #4

Hi, I'm having the same problem in Debian Etch. I'm pretty certain I have all the dependencies for AWN. Any insight would be appreciated.

masch (gmarioc) said : #5

Try to install gettext, it worked for me. Then configure and make again.

Salu2...

mrb1ggles (nmacaulay) said : #6

That didn't work. Could my running 64-bit Etch have anything to do with it?

Gaston Bougie (sprk) said : #7

I can confirm the make continued after I've installed also gettext in ubuntu 7.10
The message "/bin/sh: -o: not found" for awn doesn't show up.