Awn

Cannot open awn preferences

Asked by Pamela Boyer on 2011-01-15

I am having the same problems as discussed and solved here https://answers.launchpad.net/awn/+question/118301 however the solution doesn't work for me as I have no ~/.config/desktop-agnostic/avant-window-navigator.ini to delete. I uninstalled a previous version before installing the bzr package in the Arch Linux AUR. My setting from the previous install follow the new install in that the bar looks the same, but don't know where to go from here. When I select preference I get this :

glib.GError: Could not find the key specified: /apps/awn-applet-taskmanager/match_strength.

Any suggestions ? What am I doing wrong ? ;/

Thank you in advance :)

Question information

Language:
English Edit question
Status:
Solved
For:
Awn Edit question
Assignee:
No assignee Edit question
Solved by:
Pamela Boyer
Solved:
2011-01-20
Last query:
2011-01-20
Last reply:
2011-01-20
Michal Hruby (mhr3) said : #1

Since the error is about taskmanager, you need to delete the *taskmanager.ini file.

Well, thats the problem, I never seemed to get the .ini files. Not sure if I was looking in the wrong place or if it was just the way it installed, but I fixed it with this :

$ gconftool-2 --type int --set /apps/awn-applet-taskmanager/match_strength 99

While that fixed one problem, it created another : something about the schema file. I was able to fix it by usuin the scema file from hurleyef @ http://aur.pastebin.com/EF0LBcgd ( from this thread :http://aur.archlinux.org/packages.php?ID=12294&comments=all)
and finaly, it works like a dream.

Thanks for awswering though :)