Awn

After replacing gnome panels with AWN, ALT+F2 no longer works!

Asked by fermulator on 2011-01-09

After one has replaced all GNOME panels with the Avant Window Navigator ... the ALT+F2 shortcut (run dialogue) no longer works.

How can we restart ALT+F2 functionality w/out GNOME panels?

Question information

Language:
English Edit question
Status:
Solved
For:
Awn Edit question
Assignee:
No assignee Edit question
Solved by:
fermulator
Solved:
2011-02-25
Last query:
2011-02-25
Last reply:
2011-01-09
Alberto Aldegheri (albyrock87) said : #1

I think that you can't, Alt+F2 is a Gnome Panel's feature.
But you can try some replacement like Synapse =)
https://launchpad.net/synapse-project

moonbeam (rcryderman) said : #2

In addition to what Alberto said, most Window Manager allow you to bind a keystroke combination to the specific command. I've never understood what prompted Gnome to not do the binding of alt-f2 through the window manager.

fermulator (fermulator) said : #3

what is ALT+F2 bound to w/ GNOME panel?
A good idea moonbeam, could add the binding via window manager bindings

fermulator (fermulator) said : #4

TIP: As a workaround, as per http://ubuntuforums.org/showthread.php?p=10489175, I was able to re-add gnome-panel to the desktop, but hiding it.

So, here's what I did
 1) Installed and Configured AWN to my liking. Notably, for the purposes of this workaround, I have one AWN panel bottom right hand corner, and another docked to the left, centered.
 2) Uninstalled gnome-panel.
 3) Darn, realized that ALT+F2 no longer works w/out the gnome-panel.
 4) Did some research, and as it turns out, (currently), AWN doesn't provide a replacement functionality.
 5) Researched how to restore gnome-panel: http://ubuntuforums.org/showthread.php?p=10489175
 6) Configured gnome-panel as "hidden" : How?
     * In gnome-panel properties
       a) shrunk it down to as small as possible.
       b) made the background transparent.
       c) checked the "auto-hide" feature
       d) unchecked "expand" and set the position to "top" temporarily.
     * Hold the ALT key and left click and hold the left mouse button on the panel, and drag it exactly where AWN is. For me, I dragged to the left ,and it went beneath the AWN panel! The gnome-panel auto-hid, and now I can't see it.
 7) Voila: ALT+F2 = "Run Application", and I can't see gnome-panel, but I CAN see the pretty AWN setup.

fermulator (fermulator) said : #5

NOTE: I resolved this question as solved since a workaround exists (hacky, but it works). Hopefully at some point in the feature, AWN will provide a "Run Application" replacement.