Awn

Problems installing avant pygtk-2.0

Asked by rigo on 2007-09-05

Hi I'm having some problems installing Avant, and I was wondering if someone could help me out. I've tried a lot of things to get this fixed but I couldn't get this one.

Here is my problem whenever I run autogen.sh

checking pkg-config is at least version 0.9.0... yes
checking for PYGTK... configure: error: Package requirements (pygtk-2.0 >= 2.8.0) were not met:

No package 'pygtk-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables PYGTK_CFLAGS
and PYGTK_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

I would appreciate it

Thanks in advance.

=)

Question information

Language:
English Edit question
Status:
Answered
For:
Awn Edit question
Assignee:
No assignee Edit question
Last query:
2007-09-05
Last reply:
2007-09-05
rigo (rigoneri) said : #1

Oh and I'm using ubuntu feisty 7.04

rigo (rigoneri) said : #2

I found something on this website [URL="http://mail.codepoet.no/archives/revelation-list/2006-August.txt.gz"]http://mail.codepoet.no/archives/revelation-list/2006-August.txt.gz[/URL]
and apparently It fixed that issue:
what you have to do is:

"
> It might be worth mentioning in Revelation's INSTALL or README file that autogen.sh must be run
> first (not all users will be familiar with the automake approach).

That way, you can just:

$ sudo apt-get build-dep revelation
$ sudo apt-get -b source revelation
$ sudo dpkg -i revelation*deb

"

But I'm getting other errors though

thx

I believe the actual package is: python-gtk2

You might also need: python-gtk2-dev

See here:

http://awn.wetpaint.com/page/UbuntuFeistyHowTo

Can you help with this problem?

Provide an answer of your own, or ask rigo for more information if necessary.

To post a message you must log in.