Awn

Configure AWN under KDE

Asked by luislo06 on 2007-08-27

How do I configure AWN under KDE?

I have installed both KDE and GNOME, but I prefer to use KDE. I recently installed AWN, it launches correctly under KDE but right-clicking it doesn't come up with a configuration tool. Using gconftool doesn't work as well, it says there is no such command.

Thank you,

Luis

Question information

Language:
English Edit question
Status:
Solved
For:
Awn Edit question
Assignee:
No assignee Edit question
Solved by:
luislo06
Solved:
2007-08-31
Last query:
2007-08-31
Last reply:
2007-08-31

If you can get the preferences from the context menu, try running the command: "awn-manager"

luislo06 (luis-lopezoliveros) said : #2

Thanks andrewsomething...

I installed the beta version and now the preferences menu appear... however, I still can't modify the angle and the reflection from it...

You know how to do this?

Luis

In AWN-Manager goto General>Bar Appearance>Look and select 3D Look from the drop down list. Bar angle should be set to something around 45 and icon off set should be around 15. Restart AWN.

luislo06 (luis-lopezoliveros) said : #4

Ok, I was able to change the bar angle and offsetting using the command gconftool-2, since in the preferences dialog that I get, there's no 3D look box...

This fact made me think that I don't have an updated version of the bar. I got AWN in the SUSE repositories (the ones in opensuse.org). Do you know what's the most updated version of AWN? There are lots of pages (well, maybe not lots, but some of them) claiming they have the latest version.

Thanks again Andrew,

Luis

I'm not sure about where to find the most up to date SUSE package, but you could always install from source. It's not hard at all. Just follow the steps here: http://awn.wetpaint.com/page/SVN+Version+Installation

luislo06 (luis-lopezoliveros) said : #6

Thanks so much for your help, but please let me know the following...

I can't install it yet. The thing is that when I try to follow the steps in the website immediately above, it says a lot of packages don't exist, including bzr.

Luis

luislo06 (luis-lopezoliveros) said : #7

Ok, I already install the bar. Now my problem is the following. Say I have a launcher for a program, like firefox. After clicking on it once, it then becomes like the "task", so I'm unable to launch any more firefox instances clicking on that menu again.

You can middle click on the icon to open a second instance.

 You can middle click on the icon to open a second instance.

Also if you could please list what you did to get AWN running, so if people with SUSE and/or KDE problems might find this thread they can try your solution? Was it just different package names for the dependencies? If so could you list the SUSE names? Thanks!

luislo06 (luis-lopezoliveros) said : #10

Ok, but now the problem is I don't have a middle click button, I'm on a laptop!... what do I do?

Thanks for all your help so far...

BTW, so everyone knows:

To install AWN manager under SUSE/KDE, I couldn't do it using BZR or anything explained on the AWN wiki.

So what I did was to use the guru repositories given in the suse website. This installs what I'm guessing is the immediately previous version of AWN. But it's still very functional, it has all of the new one (or almost). However, the preferences context menu doesn't include the 3D look configuration, but... you can configure it using http://www.morphir.com/configure-avant-window-manager-under-KDE .

Just notice that the command used on the above website is gconftool, but it should be gconftool-2 (if you have updated this tool).

Have fun!

luislo06 (luis-lopezoliveros) said : #11

Nevermind, problem solved. Middle click on laptops is click with the two buttons at the same time.

BTW, I didn't mention that if you want to install the AWN in my way, then you'll have to install the beta version, which is the most recent version in guru repositories.

Thanks Andrew,

Luis