Awn

awn preferences doesn't work

Asked by klaasmoerman on 2007-08-21

hi,

a few minutes ago I installed awn, following the instructions on:

http://awn.wetpaint.com/page/UbuntuFeistyHowTo

the window navigator works fine, but when I try to open the preferences, I get this error message:
klaas@KLAAS:~$ awn-manager
Traceback (most recent call last):
  File "/usr/local/bin/awn-manager", line 199, in <module>
    awnmanager = AwnManager()
  File "/usr/local/bin/awn-manager", line 97, in __init__
    self.launchManager = awnLauncher(self.wTree, self.AWN_CONFIG_DIR)
  File "/usr/local/share/avant-window-navigator/awn-manager/awnLauncher.py", line 66, in __init__
    self.make_model()
  File "/usr/local/share/avant-window-navigator/awn-manager/awnLauncher.py", line 124, in make_model
    self.refresh_tree(uris)
  File "/usr/local/share/avant-window-navigator/awn-manager/awnLauncher.py", line 134, in refresh_tree
    self.model.set_value (row, 0, self.make_icon (i))
  File "/usr/local/share/avant-window-navigator/awn-manager/awnLauncher.py", line 168, in make_icon
    if "/" in name:
TypeError: argument of type 'NoneType' is not iterable

what's wrong, and what can I do to get it work properly?

thanks,
klaas

Question information

Language:
English Edit question
Status:
Solved
For:
Awn Edit question
Assignee:
No assignee Edit question
Solved by:
Andrew Starr-Bochicchio
Solved:
2007-08-22
Last query:
2007-08-22
Last reply:
2007-08-21

Did you previously have AWN installed? If so you might want to try a complete removal and reinstall. Some major things have changed recently and the upgrade might not have gone smoothly...

AWN has just upgraded to a more robust way to handle preference, awn-manager. There seems to be a bug effecting a number of folks, you're not alone. If that doesn't work, this one might just take a little patience; hopefully it will be resolved soon.

See this bug: https://bugs.launchpad.net/awn/+bug/133901

the complete removal did solve the problem!
thank you

HunkyBill (hunkybill) said : #3

Not sure what you did by "complete removal" to get this working. Could you possibly elaborate?

I have removed all traces of the old SVN version I had (AFAIK).. and then I manually built the program and installed it. awm-manager continues to blow out for the same reason?

I removed all the traces of my previous installation and then I installed it using the ubuntu repository:

http://awn.wetpaint.com/page/Ubuntu+Edgy+Repository

and then it worked!

see

http://awn.wetpaint.com/page/Download

for distro-specific packages