Awn

cannot open awn preferences

Asked by Soumyadeep Chanda on 2010-07-20

Hi guys! I use archlinux and just installed awn from bzr. The dock comes up, but when i go to dock preferences nothing happens, if I type awn-settings in the terminal the following messages are thrown http://www.pastebin.org/407423 Whats going on here?

Question information

Language:
English Edit question
Status:
Solved
For:
Awn Edit question
Assignee:
No assignee Edit question
Solved by:
Michal Hruby
Solved:
2010-07-21
Last query:
2010-07-21
Last reply:
2010-07-20
Alberto Aldegheri (albyrock87) said : #1

With lastest revision we have introduced some changes to gconf schema.
That error is thrown because awn-settings can't find a new config key.

I think that you can solve this issue by simply logoff and login (or restart).
In this way gconf should update schemas.

Let me know if it works :)

Well I did reboot but it didnt work, I did have the older awn installed from my distro's repo and removed it before installing the one from bzr, think the older keys might be conflicting or something. How to completely remove the previous keys? gconf-editor is not letting me delete them, I have also tried "gconftool-2 --recursive-unset /apps/avant-window-navigator" but those keys still show up in the gconf-editor.

Alberto Aldegheri (albyrock87) said : #3

Try to load this with gconftool-2 --load

http://pastebin.com/svgMjYvY

The problem is that some keys are missing.

Best Michal Hruby (mhr3) said : #4

Arch is using the keyfile backend, so you need to delete ~/.config/desktop-agnostic/avant-window-navigator.ini (note that by doing so you'll loose some settings)

Alberto Aldegheri (albyrock87) said : #5

I have a lot to learn from Michal! :) Thanks Michal

Thanks Michal Hruby, that solved my question.