Ubuntu 10.04 - "Start Awn automatically" not working

Asked by Diabolus on 2010-06-19

Hi all,
after moving on to Ubuntu 10.04 (clean install, not upgrade from 9.10) and adding Awn through the Ubuntu Software Center, I have a pretty stupid issue I hadn't in 9.10: I can't make Awn start automatically at session start!
I obviously tried to set the "Start Awn automatically" setting, but the button doesn't stay selected (I can select it, but, if I close the settings and reopen them, the button is cleared again), forcing me to manually start Awn every time.
Not a big issue, I agree... yet pretty annoying!
I also tried to launch Awn as root... only to discover that the settings are not accessible as root!
Any idea anyone out there?
Thanks in advance and regards from Italy!

Question information

English Edit question
Awn Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
justas (justass) said : #1

Please select "Start Awn automatically" option checkbox, then open Menu -> Preferences -> Startup Applications and look for the "Avant Window Navigator" entry with the "avant-window-navigator --startup" command. If there is none you can create it yourself by pressing Add button.

If startup applications settings is gone after restart/re-login, please ensure you are login in to regular gnome mode not "Fail safe" one, you can check/change this at the login screen. If problem still occurs enter in terminal "gnome-session-properties" command and look for any error messages

Diabolus (e-davolio) said : #2

Done everything as suggested: nothing seems to work.
I verified there was no AWN entry in Startup Applications, so I created it: lost upon logoff/login.
I verified I login in regular Gnome mode - no "Fail safe" mode or other oddities.
I typed "gnome-session-properties" in a terminal: the Startup Applications popped up, but no error messages anywhere.

In a personal attempt, I then uninstalled AWN, logged off, logged in again and reinstalled AWN: same stupid issue.

Thanks for the hints, but, as I said, nothing seems to work. Further ideas?

Regards from Italy!

justas (justass) said : #3

In terminal enter:

cd $HOME/.config/autostart

gedit avant-window-navigator.desktop

paste this text:
[Desktop Entry]
Name=Avant Window Navigator
Exec=avant-window-navigator --startup

Press save, test it

Diabolus (e-davolio) said : #4

Thanks justas, this time, in spite of some surprises along the way, it worked.

The surprises:
-- I had to edit the "avant-window-navigator.desktop" as root, since with my usual username I was denied permission to save the file... is this normal? I thought I was in my home directory with full read/write rights, but...
-- immediately after saving the file, in the top panel the Indicator Applet Session disappeared... why?
-- I then restarted the box (a bit extreme, I admit it, but I wanted to test it the hard way...), and finally AWN started with my Gnome session... while the Indicator Applet Session didn't appear and I had to re-add it to the top panel.

I still have the feeling that there's something wrong somewhere in my settings... even if I'm such a naive Ubuntu user that I understand very little of what's going on under the nice Gnome interface!

Well, anyway, thanks for the help and my best regards from Italy!

Mark Lee (malept) said : #5

Hm...It sounds like having ~/.config/autostart/avant-window-navigator.desktop with invalid permissions may have caused all of these problems.

Diabolus (e-davolio) said : #6

Well, Mark Lee, I confirm I found the permissions of ~/.config/autostart/avant-window-navigator.desktop all set to root.
I have no idea whether this is normal or not, but this is it.
Is this behavior of AWN a little bug, maybe connected with the new Ubuntu 10.04? I have been already using AWN in 9.10 and never had such a problem.
Should I manually change permissions to this file to allow my username full rights...?

Regards from Italy!

DC Dowd (dj-dowd) said : #7

As justas said:

"In terminal enter:

cd $HOME/.config/autostart

sudo gedit avant-window-navigator.desktop

paste this text:
[Desktop Entry]
Name=Avant Window Navigator
Exec=avant-window-navigator --startup"

What I added was the "sudo" command before the "gedit". Ubuntu will ask for the root password and will then modify permissions accordingly (as if it were being done by root).

This is the workaround that has worked for me.

Diabolus (e-davolio) said : #8

Thanks DC Dowd, but you're a bit late...
As reported in my reply of June 22, I *had to* operate as root to try justas' hint, since the file "avant-window-navigator.desktop", in spite of being in a folder in my /home, had all permissions set to root.
What's still unclear is whether the above finding this is normal for AWN or not - I just recall that nothing similar happened when installing AWN under Ubuntu 9.10.
Regards from Italy!

Mark Lee (malept) said : #9

This doesn't seem to be a problem with Awn per se, because if you run a number of programs as root (which you generally shouldn't do), it will probably create various config-type files with permissions for root only, which will probably break the program if you then run it as a normal user.

Diabolus (e-davolio) said : #10

Mark Lee,
I *had to* install Awn as root, according to the Ubuntu Software Center.
Then I use Awn under with my user profile, obviously.
Let me just recall that under Ubuntu 9.10 Awn was installed, configured and run flawlessly.

Mark Lee (malept) said : #11

Just to clarify, I did say "run", not "install".

Diabolus (e-davolio) said : #12

Clear. On my side I said "use Awn" meaning "run Awn".
I don't know what happens with Awn when I log in as normal user: all I know is that I discovered that the configuration file ~/.config/autostart/avant-window-navigator.desktop has all permissions set to root, and don't understand whether this is an issue (or even one of the causes of the problem I reported) or not.