Awn

How can I modify my launchers to improve matching?

Asked by luizfar on 2010-05-21

I have a launcher for Eclipse that doesn't match with the application when it is launched.
I took a look around and saw some solutions changing the launcher's title, but it doesn't seem to work.

Does AWN have some kind of matching customization by setting the StartupWMClass on the launcher, like Docky does?
Or any other way to make Eclipse match my launcher?

Thanks!

Question information

Language:
English Edit question
Status:
Open
For:
Awn Edit question
Assignee:
No assignee Edit question
Last query:
2010-05-21
Last reply:
2010-06-08
luizfar (luizfar-gmail) said : #1

Another I thing I noticed is that, when I launch Eclipse, a new icon is created on AWN (it is not matched).
If I keep Eclipse open and restart AWN, it will now be matched.

moonbeam (rcryderman) said : #2

What version of awn?

luizfar (luizfar-gmail) said : #3

The about window says:
0.4.1-rewrite-bzr699-lucid1-1

moonbeam (rcryderman) said : #4

run xprop on the eclipse window and look for the WM_CLASS(STRING) = line in the output.

There will be two values. You want to choose one that is unique to Eclipse (if on of them says something generic like "Java" then use to the other value).

Edit the desktop file for eclipse (it's _probably_ in /usr/share/applications/ ) and add a entry along the lines of

StartupWMClass = eclipse

(replace eclipse with an exact duplicate of the one of the WM_CLASS values)

You may need to restart awn but this will _probably_ resolve the issue.

luizfar (luizfar-gmail) said : #5

Yeap, this is the same solution used by Docky.

xprop returns:
WM_CLASS(STRING) = "Eclipse", "Eclipse"

I have a desktop file in my ~/.gnome2/panel2.d/default/launchers with this line already.
I copied this launcher to AWN and still does not work. (This is what I did with Docky)

I also tried creating a launcher in /usr/share/applications with the same content, but still nothing.

Do you know if I am doing something wrong or if there are any other solutions?
Thank you very much in any case!

moonbeam (rcryderman) said : #6

are you sure that is the launcher that is being used. You can check the paths for the launcher by starting gconf-editor and navigate to /apps/awn-applet-taskmanager/ and check the launch_paths key.

luizfar (luizfar-gmail) said : #7

You were right, it was not using any of my launchers.
I changed it to use the same that Docky uses, but AWN still doesn't match :(

moonbeam (rcryderman) said : #8

Just to make sure, you did restart awn after making the changes? I'll assume yes unless you reply otherwise.

I'll see if I can get Eclipse installed on my system later this weekend (last time I attempted it did not go well)

luizfar (luizfar-gmail) said : #9

I restarted awn, my session and the machine, just to be sure!

I have Eclipse installed from the package, not the one from Synaptic.
I just downloaded it, unpacked and created the launcher myself.

The links to download are:
32 bits: http://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/galileo/SR2/eclipse-jee-galileo-SR2-linux-gtk.tar.gz
64 bits: http://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/galileo/SR2/eclipse-jee-galileo-SR2-linux-gtk-x86_64.tar.gz

The installation is pretty straight forward if you already have a Java virtual machine.

Thank you very much, moonbeam!!!
Yo you are being awesomely helpful :)

Launchpad Janitor (janitor) said : #10

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

moonbeam (rcryderman) said : #11

Setting status to Open. Have Eclipse installed for testing purposes now.

luizfar (luizfar-gmail) said : #12

Hey Moonbeam, sorry that I couldn't reply earlier, how did it go?
Thanks!

moonbeam (rcryderman) said : #13

luizfar,

I see why there's an issue. Just haven't got around to fixing it yet. Maybe this weekend.

moonbeam (rcryderman) said : #14
Derek White (d-man97) said : #15

Thanks! This solved an on-going "annoyance" I've had with NetBeans (another java IDE).

Can you help with this problem?

Provide an answer of your own, or ask luizfar for more information if necessary.

To post a message you must log in.