Awn

A weird icon appears when awn runs from startup

Asked by adenosin_trifosfato on 2007-08-06

I run AWN in ubuntu fesity with gnome. I added this comand to my sessions: avant-window-manager because I wanted it to run from start up, rather than doing it from terminal everytime. It worked but it draws a blank square that does nothing. I want to avoid this or at least delete it, so any ideas?

Question information

Language:
English Edit question
Status:
Answered
For:
Awn Edit question
Assignee:
No assignee Edit question
Last query:
2007-08-10
Last reply:
2007-08-18

Do you have a composite manager like Compiz Fusion or Beryl? Awn requires a composite manager. If you have one, it is possible that Awn runs before Compiz/Beryl and that causes the white box. This can be solved by creating a delay before starting Awn. Create a script like this:

#!/bin/bash
sleep 10
avant-window-navigator

Make the script executable and replace avant-window-navigator command in the sessions with this script.

adenosin_trifosfato (silvag7) said : #2

I made my script like this:

#!/bin/bash
compiz --replace
sleep 10
avant-window-navigator

Its called special.sh, so I added "sh special.sh" to sessions and compiz fusion starts but avant won't even show up.

Does Awn work when you run it from terminal? If not, what does it print out?

adenosin_trifosfato (silvag7) said : #4

I want to mention that I had another problem. I had a white vertical line over the bar on the left side of my garbage bin. I read in other forums that some other people had that problem and all of them said that it was a tiny bug that would get fixed on the newer versions, but I fixed it ;-D. In my case I still use the gnome panel and I had a notification area on the panel and on awn, so I disabled the one on gnome panel and the white line is gone.

Now about the bar not showing, if I type avant-window-navigator in the terminal, it will run smoothly, however I get some output:

APPLET : /usr/lib/awn/applets/taskman.desktop
APPLET : /usr/lib/awn/applets/notification-area.desktop
APPLET : /usr/lib/awn/applets/trash.desktop

##This line appears like 10 times consecutively##
(avant-window-navigator:20499): Wnck-WARNING **: Unhandled action type (nil)

(avant-window-navigator:20499): Wnck-WARNING **: Unhandled action type (nil)
New width = 58
(avant-window-navigator:20499): Wnck-WARNING **: Unhandled action type (nil)

Edit your script to look like this:
#!/bin/bash
compiz --replace &
sleep 10
avant-window-navigator

You need that ampersand after "compiz --replace" because otherwise the script won't ever run avant-window-navigator. With ampersand the compiz will run in the background.

adenosin_trifosfato (silvag7) said : #6

I tried that and it worked, I even added another line so conky will start too. After trying lots of different sleep times this one had the best performance:

#!/bin/bash
compiz --replace &
sleep 5
avant-window-navigator &
sleep 1
conky

But the white square appeared again, the good new is that now it does something. It's the notification area... It is showing even when nothing is there. So this is the way it's supposed to be?

Notification area works only if you remove the notification area from your gnome panel. You have to restart Awn after that to get it work.

adenosin_trifosfato (silvag7) said : #8

Yeah I mentioned that above in this post, AWN works but that blank square stays even when there is nothing in the notification area.

see pic: http://ubuntuforums.org/attachment.php?attachmentid=40322&d=1186769830

That blank square is the notification area.

Can you help with this problem?

Provide an answer of your own, or ask adenosin_trifosfato for more information if necessary.

To post a message you must log in.