Is it possible to use AWN with other Window Managers like Xfce or KDE (for example)?

Asked by Nick

see above

Question information

English Edit question
Awn Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
moonbeam (rcryderman) said :

I'm not sure if this question is about Window Managers (metacity, compiz, mutter, kwin, xfwm4 etc) or Desk Environments (Gnome, KDE, XFCE etc). So I'll answer both.

WRT to Window Managers Awn has been tested with various WMs including xfwm4, Metacity, mutter, compiz, Openbox and kwin. In general it works with all of these WMs with an occasional caveat about versions and configurations. Awn version >= 0.3.9 has better overall compatibility than earlier versions and versions < 0.3.9 do require a compositor (integrated into the WM or standalone) to be active. as of 0.3.9 there is basic support for a non-composite configurations.

With regards to the Desktop Environments, awn integrates well into xfce4, Gnome. *box environments _should_, in general, work with a general caveat about versions.

Awn should also function within a KDE environment though it will pull in a large number of GTK+ related dependencies is these are not already installed. It's also fair to say that it will not integrate as nicely into this environment as well as GTK+ . KDE is probably the most problematic and least tested of the environments.

Revision history for this message
Nick (soapduk) said :

Thanks for taking the time to respond moonbeam.

My mistake - yes I did mean Desktop Environments (still memorizing my Linux jargon) rather than Window Managers. I use Ubuntu (Gnome) generally and decided to try out XFCE by installing that and selecting it at login time. It didn't seem to integrate well with AWN, but that may have been the way I installed XFCE rather than AWN itself.

Revision history for this message
mv (marxistvegan) said :

Nick I know this is solved, but I did the same and as long as you turn on compositing in XFce Settings AWN works well in Xfce at least i tested it with Xubuntu Lucid Beta 2 install