AWN-manager won't open

Asked by Kimi23

I'm running awn and awn manager on a fresh installed ubuntu 9.10. I got awn manager to run only one time after installation, then it won't open anymore, it just fails silently. if I try to run it by terminal I get this message:
cry@cry-laptop:~$ awn-manager
Traceback (most recent call last):
  File "/usr/bin/awn-manager", line 220, in <module>
    awnmanager = AwnManager()
  File "/usr/bin/awn-manager", line 136, in __init__
    self.prefManager = awnPreferences(self.wTree)
  File "/usr/share/avant-window-navigator/awn-manager/", line 109, in __init__
    self.setup_look(defs.BAR, defs.BAR_ANGLE, self.wTree.get_widget("look"))
  File "/usr/share/avant-window-navigator/awn-manager/", line 363, in setup_look
  File "/usr/share/avant-window-navigator/awn-manager/", line 377, in changed_look
    self.reload_look(0, dropdown)
  File "/usr/share/avant-window-navigator/awn-manager/", line 368, in reload_look
    if self.client.get_int(defs.BAR, defs.BAR_ANGLE) == 0:
glib.GError: Type mismatch: Expected `int' got `float' for key /apps/avant-window-navigator/bar/bar_angle
how can i fix this?
I've tried to install everything once again and it won't work, even if I cancelled every file awn-related.
Also now I have the little arrow under the lunchers when the programs are closed, that's really annoying.

Question information

English Edit question
Awn Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Michal Hruby (mhr3) said :

Try to run `gconftool-2 -u /apps/avant-window-navigator/bar/bar_angle` and see if it helps.

Revision history for this message
cantaymucxao (cantaymucxao) said :

I have the same problem.
And i solved it
I removed AWN and reinstall like that
Finally, it's worked :)

Can you help with this problem?

Provide an answer of your own, or ask Kimi23 for more information if necessary.

To post a message you must log in.