AWN-Extras fails to configure on slackware 13

Asked by j_humphrey on 2009-09-25

Even after installing rsvg, configure for awn-extras fails to detect it. I have tried --without-rsvg, --without-gnome-python-desktop but to no avail. i installed librsvg, and gnome-python-desktop. But neither one worked. I googled, and there seemed to be no fixes for it. I talked to someone in the slackware irc channel, and he said he had major problems with compiling this, and eventually gave up.

Question information

Language:
English Edit question
Status:
Answered
For:
Awn Extras Edit question
Assignee:
No assignee Edit question
Last query:
2009-09-25
Last reply:
2009-09-25
Mark Lee (malept) said : #1

In the future, please ask Awn Extras-related questions at the Awn Extras question tracker.

If you look at the output of ./configure --help, you'll notice that there are no configure flags like the ones you mention. However, there is one flag listed in the help output that you will find useful:

  --disable-pymod-checks Disable checks for Python modules

I should warn you that if ./configure cannot locate the rsvg Python module, you may have problems running the cairo-clock applet (which needs that module).

Can you help with this problem?

Provide an answer of your own, or ask j_humphrey for more information if necessary.

To post a message you must log in.