Syntax error in code won't allow the command in the instructions to complete, and it doesn't run.

Asked by mamday

I get this error when I try python ~/Auto-NDIS-0.1/ :

  File "/export/dsk1/mamday/Auto-NDIS-0.1/", line 163
    if any(baddrivers in line.split('#')[0] for line in open('/etc/modprobe.d/blacklist')):
SyntaxError: invalid syntax

Do you have any idea what could cause the error or be a possible fix?


Question information

English Edit question
Auto-NDISwrapper Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
climatewarrior (gabrieljoel) said :

Hi! Can you please post your version of I don't know what's causing this problem. When I run my version which I downloaded from the website that error doesn't come up. Can you please also tell me which distribution you are using, what version of it and what version of python. Thanks!

Revision history for this message
mamday (mamday1) said :

I am using Scientific Linux 4.6, Python 2.3.4, GCC 3.4.5, and I used the version of that I downloaded on the main page on 7/29/2008.

Revision history for this message
mamday (mamday1) said :

It was a problem with the python version. I updated to the newest python and it worked no problem. But now it says that AutoNDISWrapper does not support my wireless card :(

Auto-NDISwrapper 0.1
Please remember to always try to use the latest version of NDISwrapper with this script
Sorry, card not yet supported by Auto-NDISwrapper
Save this output as it will help other people give you support
Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)

Revision history for this message
climatewarrior (gabrieljoel) said :

Intel chipsets have open source drivers available. I don't know that distro so I don't know if they provide the drivers for you or what but you can always get them directly from Intel's site. Although I recommend that you first check if your distro provides them for you, since it will be easier to install it that way and you will also have the benefit that your distro will keep your driver up to date. Actually now that I think about it I think Scientific Linux is based on Red Hat Enterprise Linux. Most likely the driver is indeed available in your package manager. Aniway if you keep having problems just drop by here again or drop by the forums for your distro.

Revision history for this message
mamday (mamday1) said :

I have a problem with doing that, because the driver install requires a higher kernel than I can get. Scientific Linux is a pain actually. It won't let me touch the kernel, and it updates very little and is unstable in its newer versions. But thanks.

Revision history for this message
climatewarrior (gabrieljoel) said :

Maybe if you can you should try Ubuntu. It will probably be way less painful than that.

Revision history for this message
mamday (mamday1) said :

Haha. I've definitely been thinking about it. The only difficulty is then I have to figure out how to install ROOT(a high energy programming language thing) on Ubuntu and it doesn't seem like fun. I'm pretty close to trying it anyway at this point though :) And I have Ubuntu on my box, so I might play around with it a bit there before trying anything permanently damaging on my work laptop.

Revision history for this message
jimboi (crownsdozen) said :

Wow this a while a go.
It doesn't seem too hard if you don't need the very latest ROOT, even if you did you can just run grab the latest from svn instead of the snapshot thing on the website;
svn co root