Audio Recorder works, but records only silence

Asked by .

I installed audio-recorder on my KUBUNTU 15.10 (Wily Werewolf) with KDE-PLASMA-VERSION 5.4.2, Qt-Version 5.2, Kernel-Version 4.2.0-16-generic and 64bit. Details of the installation as follows:

Package name: audio-recorder
Package version: 1.7-5
Installation prefix: /usr
Executable name: /usr/bin/audio-recorder
Pixmap location: /usr/share/pixmaps/audio-recorder/
Desktop file: /usr/share/applications/audio-recorder.desktop
Icon location: /usr/share/audio-recorder/icons/hicolor/48x48/apps/
Package data location: /usr/share/audio-recorder/
Language locale directory: /usr/share/locale/
System languages are: de, C,

Everything works fine, I want to use "audio-recorder" mainly to record SKYPE-Calls for Radio-Interviews, i.e. it starts recording when i start a call, but...all the recordings are empty, there is no sound in them. I tried this with recording VLC-Player and other sound sources - and it happens all the same.

My questions:
1) Is "audio-recorder" compatible with KDE ?
2) If so, what do I do wrong that I do not capture any sound while recording? I tried everything in pavucontrol settings etc. I like your program so much, but still it does not record anything...any suggestions what could be the problem?

Question information

English Edit question
Audio Recorder Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
moma (osmoma) said :

Audio-recorder is a program that uses the GTK3 toolkit and Gstreamer audio framework.
GTK3 programs should also run on KDE-desktops. I have never seen or tested audio-recorder on KDE.
KDE may have its own recording programs?

Maybe audio-recorder is using a wrong device (audio source).

Start audio-recorder.
Use the [Show cmd]-button to show the recording command in clear text.
Goto [Additional settings] --> Recording commands --> [Show cmd].

Please run the recording command in a terminal window.
Use the pactl tool to find a correct input device.

Here is an example command.
Replace the xxxxxx with correct device (or remove the device=xxxxxxx argument all together).

gst-launch-1.0 -e pulsesrc device=xxxxxxxxxx \
! queue \
! audioresample ! audioconvert \
! audio/x-raw,rate=44100,channels=2 ! lamemp3enc name=enc target=0 quality=2 ! xingmux ! id3mux \
! filesink location=test.mp3

I hope this helps you to find out if Gstreamer (and gst-launch commands) run on your system.

Revision history for this message
moma (osmoma) said :
Revision history for this message
Launchpad Janitor (janitor) said :

This question was expired because it remained in the 'Open' state without activity for the last 15 days.