the program does not record anything

Asked by Jonathan Myles on 2012-09-19

audio-record has stopped recording anything, it simply creates emptty .ogg or .mp3 files. It has been working brilliantly for many months but has just stopped working. I haven't changed anything on my computer, and have resorted to deleting audio-recorder and re-installling it I'm still recording from

Internal Audio Analogue Stereo (Audio output)

and trying with either .OGG or .MP3 format, recording to various directories which I know exist with the default filename. I've turned the timer off. Even when I can hear output perfectly from my speakers I can't get a recording. What could I have accidentally changed to stop the program recording anything?

Thank you

Question information

Language:
English Edit question
Status:
Expired
For:
Audio Recorder Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:

I can't really help, but I have the same problem. In my case I installed Audio Recorder 0.9.1 on Pangolin 12.04 on a Dell Latitude E4200, in August 2012. It works with the microphone, but not with streaming audio.

I have the same problem with OutRec.

That suggests to me (I'm no expert!) the possibility that it may not be something you have done; maybe something has changed with a system update?

Are you using Pangolin?
What hardware are you working on?

Dai Griffiths

moma (osmoma) said : #2

Hello,
1) Install "pavucontrol" and check the device settings.
See: http://bildr.no/view/1284507
Select an entry that is "Stereo Duplex" or has both "Output" and "Input" in its name. For example "Output only" entry will switch off microphone input.

2) Check also volume settings.
See: http://bildr.no/view/1284515

3) If you change these settings, please refresh the device list in audio-recorder (and even re-select the entry). Press the small blue button beside the "Audio settings:" list.
See: http://bildr.no/view/1284519

4) Can you try to record audio from a terminal window with the gst-launch-0.10 command. Like this
$ gst-launch-0.10 pulsesrc ! queue ! audioconvert ! vorbisenc ! oggmux ! filesink location=test.ogg

You can also specify the device. Set the device="xxx" parameter, like this:
$ gst-launch-0.10 pulsesrc device="alsa_output.pci-0000_06_01.0.analog-stereo.monitor" ! queue ! audioconvert ! vorbisenc ! oggmux ! filesink location=test.ogo

List your audio devices:
$ pactl list | grep -A2 'Source #'
Names that end with ."monitor" are your audio cards which you can tap audio from (record from).

Read this posting. Answer #1 has more information about this:
https://bugs.launchpad.net/audio-recorder/+bug/1009930

Launchpad Janitor (janitor) said : #3

This question was expired because it remained in the 'Needs information' state without activity for the last 15 days.