Detecting Creative Zen Mozaic

Asked by Erik on 2008-06-30

I'm trying to connect my new Creative Zen Mozaic, but it is not detected by Amarok, Gnomad2, or Rythmbox.

In Amarok, clicking Autodetect Devices in the settings configurations menu produces

"No new media devices were found. If you feel this is an error, ensure that the DBUS and HAL daemons are running and KDE was built with support for them. You can test this by running "dcop kded medimanager fullList" in a Konsole window."

Testing:

ted@beecom:~$ dcop kded medimanager fullList
ERROR: Couldn't attach to DCOP server!

I tried manually adding a device, in Amarok --- "Creative Nomad Jukebox Media Device" is one of the options, but then it asks for a pre-connect command, of the form "mount %d" or "mount %m", where d is a device node, m is a mount point.

At this stage my very limited Linux expertise is used up. In case it's of any use, "lsusb" produces

ted@beecom:~$ lsusb
Bus 003 Device 005: ID 041e:4161 Creative Technology, Ltd
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 003: ID 045e:0040 Microsoft Corp. Wheel Mouse Optical
Bus 001 Device 001: ID 0000:0000

Gnomad2 just says "No jukeboxes found on USB bus"

In Rythmbox, "Scan removable media" results in "0 songs".

I'd be very grateful for any help on how to prodeed from here, with Amarok or Gnomad2 or Rythmbox, or anything else.

Thanks,

Ted.

Question information

Language:
English Edit question
Status:
Solved
For:
Audio Player Edit question
Assignee:
No assignee Edit question
Solved by:
Erik
Solved:
2008-07-01
Last query:
2008-07-01
Last reply:
2008-06-30

If you want to give Amarok a chance, make sure you have Menu->Settings->USB->MSC activated and then plug your player.

Erik (iceman80403) said : #2

Hi,

Thanks for the quick response. I couldn't find the sequence of selections you listed in either Amarok or elsewhere in Ubuntu. I kept working with it and eventually it detected my player and even all artists on it, but it gave me an error stating it couldn't open the file and would frequently state kmail couldn't be found and crash.

I discovered Rythmbox and it worked great automatically detecting my player.

Thanks for your help.

Ampers (ampers) said : #3

This has also helped me.

I think the "Menu->Settings->USB->MSC" was for the Outer Mongolian version of Ubuntu as it certainly didn't mean anything to this 8.04 UK user.

But I took your advice and have also moved to Rhythmbox.

Not I have my Creative Zen working well.

Fir this, Erik, thank you.

Ampers.

Erik (iceman80403) said : #4

You're welcome! I'm glad it worked for you too. I've been unsuccessfully trying to get album art to work with Rythmbox though. If you get it to work I would really appreciate it if you let me know how!

-Erik

liss (beda-hauga) said : #5

Hi, I also got the creative zen mozaic player, but I cant manage to use it in Linux.. I have downloaded a few programs as: libnjb, libmtp and gonomad2 but I don't know how to open the programs...

Can u help me?