Cannot build ARToolkit under ubuntu

Asked by Rodrigo Pinheiro on 2007-04-04

Hi there,

I'm trying to build ARToolkit under Ubuntu Feisty but without success. After executing the Configure script I get the following errors when I execute make:

cc -c -O -I/usr/X11R6/include -g -I../../../include ccvt_i386.S
ccvt_i386.S:32:27: error: linux/linkage.h: Ficheiro ou directoria inexistente
make[2]: ** [../../libARvideo.a(ccvt_i386.o)] Erro 1
make[2]: Saindo do diretório `/home/rodrigo/Temporários/ARToolKit/lib/SRC/VideoLinuxV4L'
make[1]: ** [all] Erro 2
make[1]: Saindo do diretório `/home/rodrigo/Temporários/ARToolKit/lib/SRC'
make: ** [all] Erro 2

I managed to check all the dependencies to solve most of the build problems, but know I got stucked. Could you please help me?

Thanks and best regards
Rodrigo Pinheiro

Question information

English Edit question
ARToolkit libraries Edit question
No assignee Edit question
Last query:
Last reply:
Rafael Santin (rasantin) said : #1

Did you try to install libxmu-dev, libxi-dev and libxext-dev packages ?

Krister Svanlund (adsummodo) said : #2

I get the same error and have all the mentioned lib's installed. Also running Feisty.

Rodrigo Pinheiro (ametade) said : #3

Actually, I didn't manage to build ArToolkit either...

Does anybody has some information on how to build this thing?

Rafael Santin (rasantin) said : #4

If you are using v4l. Edit ARToolKit's Configure, changing the CFLAG's parameters:
CFLAG="-O -I/usr/X11R6/include"
CFLAG="-O -I/usr/src/linux-headers-`uname -r`/include":

Diff showing the changes.
--- Configure 2006-09-18 01:52:15.000000000 -0300
+++ ../../artoolkit/Configure 2007-06-25 23:12:18.000000000 -0300
@@ -41,7 +41,7 @@
     if [ "$ANS" = "1" ]
- CFLAG="-O -I/usr/X11R6/include"
+ CFLAG="-O -I/usr/src/linux-headers-`uname -r`/include"

After you've made the changes run ./Configure.

Celso Providelo (cprov) said : #5

Hi guys,

Well, there are clear evidences that <linux/linkage.h> doesn't belong to the linux user-space, that's why it's not shipped with linux-libc-dev anymore. See bug #73336 for one of the ubuntu implications and, if you are curious about the real reason, see

The current experimental package became FTBFS in feisty due to this problem.

So the solution I found will be soon in, I simply inlined the required bits from linkage.h into ccvt_i386.S.

Celso Providelo (cprov) said : #6

The unofficial ubuntu/feisty/i386 packages with the mentioned *hack* are in:
To install them you have to add the following line in your /etc/apt/sources.list:
deb feisty main restricted universe multiverse
$ sudo apt-get update
$ sudo apt-get install artoolkit-dev python-artoolkit
It would be very nice if you can test the package and file bugs on this product about any problem.
Thank you.

Celso Providelo (cprov) said : #7

and for now we will consider this question 'Solved'.