Bitte helfen Sie! Unable to locate complete 0.2.8.3.4 build files

// Bitte helfen Sie! Unable to locate complete 0.2.8.3.4 build files

z. Hd.: z-man
Guten tag, mein Herr.

I have been unsuccessful to recompile program, as you have instructed.
After many downloads from SourceForge, Launchpad, git-Hub, and libSDL,
i still can not find matching code and libraries for armagetronad.exe
version 0.2.8.3.4 Once i have completed test compile with working build,
only then should i attempt any changes to menu items or view ports.
If you have this full build (+ win32_libs) , and would be so kind, please upload
them to this link below.

https://drive.google.com/drive/folders/0BwMpRqhS7tnoWkNYcTFfdGZKbFk?usp=sharing
Danke schön.

Wir sprechen uns bald.
Tschüß.
- Aleksandr 14:02:00 27.05.2017
<email address hidden>

Question information

Language:
English Edit question
Status:
Solved
For:
Armagetron Advanced Edit question
Assignee:
No assignee Edit question
Solved by:
Manuel Moos
Solved:
2017-05-29
Last query:
2017-05-29
Last reply:
2017-05-28

Windows XP Pro 32 sp3 (5.1.2600.6748)
Code::Blocks 13.12.9501 (SDK 1.19.0)
GNU GCC 4.6 mingw32-gcc
Python 2.7.1

Best Manuel Moos (z-man) said : #2

If you want to make changes to the source, I would strongly recommend against using 0.2.8.3.4 as a base. It's development requirements on Windows are ancient and hard to fulfil. Stick to the current state of the 0.2.8 branch or of 0.4. Instructions for that are here:
http://wiki.armagetronad.org/index.php?title=Windows_Development

If you absolutely must use 0.2.8.3.4, that only can be compiled with Code::Blocks 1.0RC2. Grab the Armagetronad source zip from here: https://sourceforge.net/projects/armagetronad/files/stable/0.2.8.3.4/armagetronad-0.2.8.3.4.src.zip/download

The relevant winlibs to use should be here: https://sourceforge.net/p/armagetronad/code/HEAD/tree/armagetronad/tags/0.2.8.3.4/winlibs/
Although I can't be sure those were the ones actually used for the build; I just kept reusing the ones from the earlier 0.2.8.3 builds. And there is no convenient correct way to get them from bzr.

Convoluted, confusing and outdated information on that process can be found here: http://wiki.armagetronad.org/index.php?title=Windows_Development_System
The gist ist: fetch winlibs, unzip source zip so they are parallel to each other, open code::blocks workspace, build all, call makedist_gcc.bat to copy the dll files the executable needs.

Thanks Manuel Moos, that solved my question.

-- cType.h || !defined __STRICT_ANSI__ //Makes Windows unhappy. :-D
++ tString.cpp #include <time.h> //Undefined vars error.
../dist/armagetronad.exe: //Import lib files mismatch.
REN libSDL.dll.a libSDL.a
REN libSDL_image.dll.a libSDL_image.a
REN libSDL_image.dll.def libSDL_image.def
REN libSDL_mixer.dll.a libSDL_mixer.a
REN libSDL_mixer.dll.def libSDL_mixer.def

Yes, i like this older and smaller code version.
Working Build.
Thank you very much for all your help.

Manuel Moos (z-man) said : #5

Really hard to tell without specifics, but those are precisely the kind of errors you usually get if you do not use the matching version of Code::Blocks. It's a bummer they don't even give you a warning about that when opening a workspace or project, but here we are. Armagetronad 0.2.8.3.4 requires Code::Blocks 1.0rc2, current sources require 13.12. Precisely those versions, not those versions or later. And the versions that include the Mingw compiler, that's the actually important component.