Problem adding new country to soviet side

Asked by Benedict Wolf on 2017-04-12

Hello,

I am trying to add a new country to Soviet Side, China. However when it gets into game, the computer only builds Tesla Reactor and Battle Bunkers then chill for the rest of the game.

I've made sure I add China to every House lists possible but still nothing happens

Thanks ahead for any help

Here is my configuration:

[Sides]
GDI=British,French,Germans,Americans,Alliance
Nod=Russians,Africans,Confederation,Arabs,China
ThirdSide=YuriCountry

Civilian=Neutral
Mutant=Special

[Countries]
0=Americans
1=Alliance
2=French
3=Germans
4=British

5=Africans
6=Arabs
7=Confederation
8=Russians
9=China

10=YuriCountry

;Custom

11=GDI
12=Nod
13=Neutral
14=Special

[China]
UIName=Name:China
Name=China
Suffix=Soviet
Prefix=B
Color=DarkRed
Multiplay=yes
Side=Nod
SmartAI=yes
File.Flag=cnii.pcx
File.LoadScreen=ls800china.shp
File.LoadScreenPAL=mplps.pal
File.Taunt=tauam%021.wav
LoadScreenText.Name=Text:Blank
LoadScreenText.SpecialName=Name: s_China
LoadScreenText.Brief=LoadBrief:China
MenuText.Status=LoadBriefShort:China
RandomSelectionWeight=0 ;Put it as 0 so they won't pop up in random country selection for now.

Question information

Language:
English Edit question
Status:
Answered
For:
Ares Edit question
Assignee:
No assignee Edit question
Last query:
2017-04-12
Last reply:
2017-04-20
albert25 (albert-liwagon) said : #1

Just add China in every Soviets Buildings , units and Infantry .

and Check the Uppercase letter -----> China ( not lowercase letter like -----> china)

For Example:

; Soviet Barracks
[NAHAND]
UIName=Name:NAHAND
Name=Soviet Barracks
BuildCat=Tech
Prerequisite=POWER,NACNST
Strength=500
Armor=steel
TechLevel=2
Adjacent=2
Sight=6
Owner=British,French,Germans,Americans,Alliance,Russians,Confederation,Africans,Arabs,YuriCountry, China<-----here
AIBasePlanningSide=1 ;gs 0 for Good, 1 for Evil
Cost=500
Points=30
Power=-10
Factory=InfantryType
Crewed=yes
Capturable=true
Explosion=TWLT070,S_BANG48,S_BRNL58,S_CLSN58,S_TUMU60
DebrisAnims=DBRIS2SM,DBRIS3LG,DBRIS3SM,DBRIS4LG,DBRIS4SM,DBRIS5LG,DBRIS5SM,DBRIS6SM,DBRIS7LG,DBRIS7SM,DBRIS8LG
MaxDebris=8
MinDebris=4
ThreatPosed=0 ; This value MUST be 0 for all building addons
ExitCoord=0,0,0
NODBarracks=yes
;DamageParticleSystems=SparkSys,SmallGreySmokeSys,BigGreySmokeSys
DamageSmokeOffset=480,96,125
AIBuildThis=yes
Spyable=yes
;WantsExtraSpace=yes ; gs This will look for a space AIBaseSpacing+1 when the computer places, but will settle for AIBasSpacing
ImmuneToPsionics=no ; defaults to yes for buildings, no for others

Can you help with this problem?

Provide an answer of your own, or ask Benedict Wolf for more information if necessary.

To post a message you must log in.