Launch base always downloading ares 0.1

Asked by PhenomImbalance on 2014-03-23

I've been using ares via a batch file in launching.
But since Launch base offers more comfort( especially in making life easier in playing different mods), i tried to use the launch base program.

But my mod is using ares 0.5 and launch base is always launching it via ares 0.1p.
It always downloads ares 0.1(even when i try to put ares files like ares.dll in the game directory, I've even tried to put it in the resource folder in the launch base directory). Still it uses ares 0.1.
If i try todisconnect the internet, the game won't launce saying it must download latest version of ares.

So how i may make the launch base use ares 0.5???

Question information

Language:
English Edit question
Status:
Solved
For:
Ares Edit question
Assignee:
No assignee Edit question
Solved by:
Graion Dilach
Solved:
2014-03-23
Last query:
2014-03-23
Last reply:
2014-03-23
Best Graion Dilach (graiondilach) said : #1

Yes, this is a known issue.

You have to force LB to use custom Ares versions. To achieve that, you have to first tell LB that the mod does not 'use' Ares, so UseAres=no within the mod's launcher/liblist.gam.

When you're done with this step, just create a syringe subfolder alongside the others (like shp, vxl, video and all that), put Ares 0.5 dll and inj there and you're done. Restart LB if you did all these changes while it was open, and if you did this right, LB reports that your mod uses Custom Ares DLL.

You're losing the meant Ares auto-updater function with this, but since it doesn't even work, there's nothing to lose. :P

Also, if you plan to use Ares's loose sound feature, never put the sounds into the sound subfolder. That won't work, but inserting them in your theme folder will.

PhenomImbalance (fcord) said : #2

I tried this already and it worked!!!!!!

PhenomImbalance (fcord) said : #3

Thanks Graion Dilach, that solved my question.