Problem with when you make the AI to mplay in new faction

Asked by PhenomImbalance on 2013-09-18

I have added the new country after the yuricountry at number 10 before the GDI
But i always got the game over message when I start the Game....
It is solved when I put the new country at number 16 after the civilians,mutants etc.....
Now I can play the new country but when I try to make the Brutal AI choose that country,
I always get INternal errors.
I think the problems go withthe sides which I put after the NOD before the civilians at side section.
Do you think it will be alright if i put it at the end?
how may iput the AI base planning side? Is it 4 or 5?

Question information

Language:
English Edit question
Status:
Answered
For:
Ares Edit question
Assignee:
No assignee Edit question
Last query:
2013-09-18
Last reply:
2016-03-30
Graion Dilach (graiondilach) said : #1

There are a lot of issues and not clean stuff here.

If you put your new side's first country before GDI (that would be the correct way) then AIBasePlanningSide is 3. (Allies is 0, Soviets is 1 and Yuri is 2).

The crash you get from the AI is probably due to the fact that your new side doesn't have an AI and [General]UseMinDefenseRule is still set to yes.

Ofcourse if you add an except I could tell more.

PhenomImbalance (fcord) said : #2

OK. I have now solved this Internal error issue by making the new side appear at the last and set AIBaseplanning side to 5
Looks olike this
[Sides]
GDI=
NOD=
ThirdSIde=
Civilians=
Mutants=
Empire=Japanese

However
I think it's up now to the AI.INI
I have created only 5 ntriggers and 5 teamtypes just to test if its working
1deploy mcv
2-3defence
4-5atak
I have set the AI's Side ownership to 6------corect me if Imwrong
But only the deploy MCV trigger works and the AI doesnt buy new other units
The Taskforce and Scriptypes is OK as I had already modifying AI.INI long ago.
I have even tried to change SIde ownership to 0 and add house owner to japanese but it still doesnt use that units.
Is it because that I only have few triggertypes and teamtypes why the Ai doesnt use that units?
I didn't add so much because I'm just testing it and It would be a waste of time if I add alot but its faulty/

Graion Dilach (graiondilach) said : #3

Show me your Countries list.

Graion Dilach (graiondilach) said : #4

AIBasePlanningSide depends on the Countries list.

PhenomImbalance (fcord) said : #5

defaualt for 10 skirmish houses

11=GDI
12=NOD
13=Civilians
14=Mutans
15=Japanese

I put AI Base planning side to 6 and the ai builds bases except for defences.
I have already filled the AI section that is buildpower etc...

Graion Dilach (graiondilach) said : #6

http://ares-developers.github.io/Ares-docs/new/sidescountries.html#sides

See Side->AI.BaseDefense(Count)s.

Do you have defensive teams for your dummy AI OR have you set General->UseMinDefenseRule to no?

For testing cases, you could also set both General->MinimumAIDefensiveTeams=0,0,0 and General->MaximumAIDefensiveTeams=0,0,0 as well.

albert25 (albert-liwagon) said : #7

AllowedToStartInMultiplayer=yes

(add this code in Infantry and tanks to avoid IE in your new country)

Can you help with this problem?

Provide an answer of your own, or ask PhenomImbalance for more information if necessary.

To post a message you must log in.