problems with syringe

Asked by chad larson on 2013-05-12

i cant get syringe to run
an error keeps coming up that says: You cannot run Syringe just like that, Please run a Syringe control file.
how do i do this please help

Question information

Language:
English Edit question
Status:
Solved
For:
Ares Edit question
Assignee:
No assignee Edit question
Last query:
2013-05-12
Last reply:
2013-09-02
Graion Dilach (graiondilach) said : #1

Where have you got your Ares from?

If it's from the Ares page, use the RunAres.bat.

Or drag'n'drop gamemd.exe onto Syringe.

Control files were used back in the day but nowadays it's just a parameter which Syringe needs, Syringe itself isn't hardcoded to which executable it should inject the found dlls.

chad larson (larsonchad54) said : #2

you don't get it i did download it from the ares site and i've tried but it wont let meuse syringe so i cant inject the dlls that are in ares so i can use like reverse engineering, spotlights etc...

chad larson (larsonchad54) said : #3

and also this still didn't answer my question but how do i get syringe to work!!!

Graion Dilach (graiondilach) said : #4

There is a RunAres.bat file in the package you downloaded. Double-click on that.

chad larson (larsonchad54) said : #5

but it doesn't inject the dll files

Graion Dilach (graiondilach) said : #6

Do you use Comodo or ZoneAlarm?

chad larson (larsonchad54) said : #7

i don't think so. Why?

Graion Dilach (graiondilach) said : #8

"Comodo Internet Security

Commendably, Comodo Internet Security actually complains when one program tries to modify another at runtime, unlike other anti-virus products, which happily let it happen. Unfortunately, this is exactly the way Syringe/Ares works, making it a so-called “false positive”.

In order for Syringe/Ares to work with Comodo Internet Security, you have to make the following changes to Comodo’s settings (courtesy of eva-251):

gamemd.exe and Syringe.exe need to be in the “Trusted Files” list.
Under “Computer Security Policy” -> “Defense+ Rules”, gamemd.exe and Syringe.exe need to be marked as “Installer or Updater”.
“Defense+ Settings” -> “Execution Control Settings” -> “Detect shellcode injections” should be checked.
Under “Defense+ Settings” -> “Execution Control Settings” -> “Exclusions:” add Syringe.exe, Ares.dll, Ares.dll.inj, gamemd.exe.
This should allow Syringe/Ares to work properly.

ZoneAlarm

ZoneAlarm is known to prevent Syringe/Ares from starting. In case Yuri’s Revenge does not start (Syringe closes immediately), add gamemd.exe and Syringe.exe to the exceptions list.

If this does not help, try to stop the service called ZoneAlarm ForceField Service (ISWSVC.exe). This is not recommended and you should re-enable the service as quickly as possible."

chad larson (larsonchad54) said : #9

ok so i added syringe to the exceptions list but it still says that i need to run a control file

Graion Dilach (graiondilach) said : #11

Open your RA2 folder with Total Commander or launch a command prompt there.

Type Syringe "gamemd.exe" -log and tell me what happens after.

chad larson (larsonchad54) said : #12

nothing happened same old yuri's revenge no reverse engineering no nothing

Graion Dilach (graiondilach) said : #13

In the bottom left corner of the main loading screen does it say Ares is loaded?

chad larson (larsonchad54) said : #14

ues it does it says ares is loaded, version 0.3 (I have the unstable build for mods that require it), Warning this version of ares is considered unstable

Graion Dilach (graiondilach) said : #15

I see.

Most features of Ares like ReverseEngineering requires a modder to enable then in the game. Without modding capabilities only the bugfixes will be noticable in the game. If you can mod already, consult with the documentation how to enable such features. Teaching you how to mod YR is out of this topic's scope.

In case of Speeder's old showcase videos, he did modded MO for the suit of those videos back then, most were only propaganda edits.

Graion Dilach (graiondilach) said : #16

Setting this as solved, since initial issue was solved and no additional issue came up after 90 days.