ares 0.2 mouse frozen

Asked by luxycomplex on 2012-11-07

I can play Yuri's Revenge with the "unstable ares 0.1" but when using ares 0.2 the mouse cannot be used, it's frozen. I have test all compatibility modes, VideoBackBuffer (yes and no), change power option (high performance and energy saver), putt and remove ddraw.dll inside game folder, modify mouse options in control panel, still nothing work. If I press Ctrl button, the mouse can be moved but will freezes again after it. This problem has haunted me for about 1 month or more.. Really need help here. I have test several versions of ares 0.2, none gives any different effect.. I just wanna enjoy TSun in Advanced YR engine, especially NEW ADVANCED SIDEBAR..

System: Lenovo core-i5, radeon 6730, 4G RAM, Win7 32bit
RA2 and YR updaded to latest official patches.

Thanks to your attention..
Yours sincerely, luxycomplex, an insignificant supporter for Homeworld 3.

Question information

Language:
English Edit question
Status:
Solved
For:
Ares Edit question
Assignee:
No assignee Edit question
Solved by:
luxycomplex
Solved:
2012-11-08
Last query:
2012-11-08
Last reply:
2012-11-08
Graion Dilach (graiondilach) said : #1

Unstable Ares 0.1 means a lot. If you could mention an explicit unstable which worked, then we would have something to compare with.

Worst case scenario, you can take one of the 0.2 testing branches off from the unstable server and tell if those still works.

luxycomplex (gamemail2013) said : #2

From Rewire Mod:

"version of Ares distributed with this mod is an unstable testing version 0.1.1164
For stable public version 1.0 please follow: http://www.rp2.strategy-x.com/

Ares Testing Version Disclaimer Wrote
The version of Ares distributed with this mod is an unstable testing
version not meant for public consumption. The Ares developers do not
support the usage or distribution of testing versions with public
mods. This version of Ares has a certain likelihood of being broken
in various ways, including, but not limited to:
* frequent Internal Errors
..etc

We, the authors of this mod, consider this version of Ares stable enough
for general distribution, but we are required to stress that the Ares
developers disagree and do not support this move."

I (luxycomplex) have test that version of Ares in unmodded YR and there are no mouse problem.. This Rewire Mod (Build 005 or Alpha) also run okey.. Excepts: Building and terrain from TS not used (the game still uses YR) but the infantry and unit from TS used.

Ok ..I have test: various-fixes.12.113.597.tar.gz.. No Mouse problem too..
Testing ares_0.2p1, mouse freezes.
Version: 12.260.1141, freezes.
ft-missiles.12.289.966, freeze
v02-mix3.12.34.1250, ok.. not freezin..
v02-mix1.12.19.608, freezin again..
ft-cyclicgattling.12.289.823, freeezin
gd03.12.173.1054, chrono legionnaired..
v02-mix2.12.19.595 ok.. no mouse issue
v02.12.305.1337 zapped by chrono leg..
 Sorry.. if it's too long list..

Again, thank you for the attention..
Your sincerely luxycomplex, a laughable HW3 supporter

Graion Dilach (graiondilach) said : #3

Hm.

What happens if you take a freezing dll's inj open it with Notepad, and remove the 4BA61B = DSurface_CTOR_SkipVRAM, 6 line from it?

luxycomplex (gamemail2013) said : #4

Hmmm..

Solved.. As simple as that..

luxycomplex (gamemail2013) said : #5

Thank a lot again..

Hmm. I wonder what that line means.

Graion Dilach (graiondilach) said : #6

It's a good thing it got solved.

Howebver it is still seems to be buggy for me and I think this shall be converted into a minor bugreport... which I'll do for now.

Graion Dilach (graiondilach) said : #7

Sadly, I don't know what the line means in this case, I just compared the diffs you pinpointed out and determined the above as the sole possible cause regarding that, since this was the first time I ever heard about such issue.