apturl giving 'Package XXX is virtual.' when mixing i386 and amd64

Asked by Javier-puche-u on 2015-07-07

Dear all,

 In trusty and before (I did not try later on) apturl will give the subject's message if trying to install a i386 package in amd64 host without specifying the :i386 suffix, and the other way around: trying to install a :i386 package in i386 host specifying the :i386 suffix

 The things is that apt-get install does not have this behaviour.

 Trying to put a link to, for example, apt://acroread-bin, will not work either for i386 or for amd64 depending on weather the :i386 is specified or not, while apt-get install handles properly.

 I tried to update apturl with latest ubuntu versions (vivid, etc.) but it breaks too many dependencies, before taking a look to the source code I would like to know if I should report it as a bug, if someone has already detected this behavior, and if there is any workaround.

Thanks a lot for your help. Best Regards,

Javier.

Question information

Language:
English Edit question
Status:
Solved
For:
apturl Edit question
Assignee:
No assignee Edit question
Solved by:
Javier-puche-u
Solved:
2015-07-07
Last query:
2015-07-07
Last reply:

Sorry, I see it was already reported here: https://bugs.launchpad.net/ubuntu/+source/apturl/+bug/230760 , I will update that bug report.