cant istall packages from ubuntu software

Asked by George on 2011-04-14

Hello, last night i tried to istall xpdf from ubuntu software center. When about half of the bar was fulled, it got stuck , and (ffs) there was an interruption of power !!!! About 5 minutes later , when power was restored, i tried to istall again xpdf and the following message occured :

An unhandlable error occured

There seems to be a programming error in aptdaemon, the software that allows you to install/remove software and to perform other package management related tasks. Please report this error at http://launchpad.net/aptdaemon/+filebug and retry

Details

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 779, in simulate
    return self._simulate_helper(trans, status_path)
  File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 958, in _simulate_helper
    return depends, status, self._cache.required_download, \
  File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 218, in required_download
    pm.get_archives(fetcher, self._list, self._records)
SystemError: E:I wasn't able to locate file for the gsfonts-x11 package. This might mean you need to manually fix this package.

The point is that the very exact message shows up when i try to install any other package from Ubuntu Software Center, even games !!
what can be done to fix this ?
Thank for your time
If possible , email me with your answer :)

Question information

Language:
English Edit question
Status:
Solved
For:
Aptdaemon Edit question
Assignee:
No assignee Edit question
Solved by:
George
Solved:
2011-05-16
Last query:
2011-05-16
Last reply:
2011-05-14
Sebastian Heinlein (glatzor) said : #1

This is a long standing error and we haven't yet found the root of it. So it would be very nice if you could assist here by providing us more data and information - before you resolve it.

Could you please make a copy of the following directories and files and send it to me?

/var/cache/apt/pkcache.bin
/var/lib/apt/lists
/var/lib/dpkg/status
/etc/apt/sources.list
/etc/apt/sources.list.d
/var/log/dpkg.log

Furthermore you could start aptdameon in debug mode and also send me the output. Run the following command in a terminal:

sudo aptd -td --replace

And install something in software-center.

Afterwards you could run the following commands to resolve the issue:
sudo dpkg --configure -a
sudo apt-get update
sudo apt-get install -f

It would be nice to have the output from the above commands too.

Thanks!

mundayi michel (mundayimichel) said : #2

I can't install a package from ubuntu and I can't read my DVD/CD from ubuntu

George (gemistass) said : #3

Thanks for your help, but i solved the problem at the same day.
I just removed xpdf (sudo apt-get remove xpdf) , and installed it again (sudo apt-get install xpdf), and the problem magically solved :)