Every Time I use a loop I get an error say another process is a accessing the file

Asked by king on 2014-09-26

Hi guys,

I'm really new to appy and I'm playing a bit with appy.pod.
I just got to the point in the tutorial where it says you can add a loop with LibreOffice notes.
My fist problem now is, I don't have LibreOffice installe, instead I have to use Lotus Symphony and I'm not! allowed to install LibreOffice on my work station.
So my first question is, is a note field the same as a comment field? Because when I try to implement a simple do-loop, for example:
do text if not beingPaidForIt (<= from the tutorial)
when i try to run this I get the following error:

Traceback:
File "D:\python2.7\lib\site-packages\django-1.6.7-py2.7.egg\django\core\handlers\base.py" in get_response
  112. response = wrapped_callback(request, *callback_args, **callback_kwargs)
File "D:\workspace\certwb\main\views.py" in start_document
  34. renderer.run()
File "D:\python2.7\lib\site-packages\appy\pod\renderer.py" in run
  456. FolderDeleter.delete(self.tempFolder)
File "D:\python2.7\lib\site-packages\appy\shared\utils.py" in delete
  32. os.remove(os.path.join(root, name))

Exception Type: WindowsError at /start_document/
Exception Value: [Error 32]
The process can not access the file, as it is used by another process
 'D:\\workspace\\files\\tmp\\tmp.odt.1411732664.770000\\content.xml'

I started the pod with the following lines:

year = 2014
 kw = 39
 renderer = Renderer("files/template/Template.odt", {"year":year, "kw":kw}, "files/tmp/tmp.odt")
 renderer.run()

FYI:
I'm using python 2.7 with django-framework 1.6
If I'm running the template only with conditional text fields there is no problem, this only happens when I insert a comment with some kind of loop

some one experinced this befor?or does anybody has a solution to this problem?
thx

Question information

Language:
English Edit question
Status:
Solved
For:
Appy Edit question
Assignee:
No assignee Edit question
Solved by:
king
Solved:
2014-09-29
Last query:
2014-09-29
Last reply:
king (samsemilia7) said : #1

I installed Libreoffice at home and now the problem seeems to be solved